易语言DLL公开程序中无法自定义数据类型解决办法

在编写动态链接库时发现无法公开自定义数据库,只能提供基本数据库且不包含字节集。

 

其报错为

错误(10063): 被取地址的子程序“Entrance”的参数 2 必须是基本数据类型,且不能为字节集。

那么怎么解决这个问题了

易语言DLL公开程序中无法自定义数据类型解决办法

我们可以使用“强制交换变量”这个命令
对外提供通用变量,外部程序提供参数后强制交换即可解决这个问题
代码如下
.版本 2
.子程序 ent, , 公开
.参数 int
.局部变量 ints, Pinte
强制交换变量 (int, ints)
信息框 (ints.p, ints.b, , )
易语言DLL公开程序中无法自定义数据类型解决办法

 

 

 

历史上的今天
十一月
3
亦行
  • 版权声明: 发表于 2019-11-0317:21:10,共 232 字。
  • 转载注明:https://www.nanzl.com/archives/1566

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: