易语言DLL公开程序中无法自定义数据类型解决办法

在编写动态链接库时发现无法公开自定义数据库,只能提供基本数据库且不包含字节集。

 

其报错为

错误(10063): 被取地址的子程序“Entrance”的参数 2 必须是基本数据类型,且不能为字节集。

那么怎么解决这个问题了

易语言DLL公开程序中无法自定义数据类型解决办法

我们可以使用“强制交换变量”这个命令
对外提供通用变量,外部程序提供参数后强制交换即可解决这个问题
代码如下
.版本 2
.子程序 ent, , 公开
.参数 int
.局部变量 ints, Pinte
强制交换变量 (int, ints)
信息框 (ints.p, ints.b, , )
易语言DLL公开程序中无法自定义数据类型解决办法

 

 

 

历史上的今天
十一月
3
亦行
  • 本文由 发表于 2019-11-0317:21:10
WindowsAPI易语言内介绍和使用 技术分享

WindowsAPI易语言内介绍和使用

引用百度百科介绍:Windows 这个多作业系统除了协调应用程序的执行、分配内存、管理资源之外, 它同时也是一个很大的服务中心,调用这个服务中心的各种服务(每一种服务就是一个函数),可以帮应用程式达到...
了解和掌握易语言面向对象 技术分享

了解和掌握易语言面向对象

许久许久,忙于工作和结婚无法更新一些实用的技术文章,趁女神节有点业余时间写下这篇“面向对象”技术分享文章 前言  希望你在看完这篇文章后能够了解 面向对象的含义,了解什么是面向对象 知道什么是类,了解...
分析以及实现FPS网络游戏自动瞄准漏洞 技术分享

分析以及实现FPS网络游戏自动瞄准漏洞

前言:这是亦行搜寻到的一篇怎么寻找FPS游戏自动瞄准漏洞和实现的文章,比较有学习价值。 分析 一、了解FPS游戏自瞄漏洞 经常玩游戏的朋友,应该知道FPS游戏,例如:穿越火线,逆战等等,他们的特点就是...
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: