易语言DLL公开程序中无法自定义数据类型解决办法

yx 技术分享易语言DLL公开程序中无法自定义数据类型解决办法已关闭评论151,0422字数 232阅读0分46秒阅读模式

在编写动态链接库时发现无法公开自定义数据库,只能提供基本数据库且不包含字节集。

 文章源自楠竹林-https://www.nanzl.com/archives/1566

其报错为文章源自楠竹林-https://www.nanzl.com/archives/1566

错误(10063): 被取地址的子程序“Entrance”的参数 2 必须是基本数据类型,且不能为字节集。文章源自楠竹林-https://www.nanzl.com/archives/1566

那么怎么解决这个问题了文章源自楠竹林-https://www.nanzl.com/archives/1566

易语言DLL公开程序中无法自定义数据类型解决办法文章源自楠竹林-https://www.nanzl.com/archives/1566

我们可以使用“强制交换变量”这个命令
对外提供通用变量,外部程序提供参数后强制交换即可解决这个问题
代码如下
.版本 2
.子程序 ent, , 公开
.参数 int
.局部变量 ints, Pinte
强制交换变量 (int, ints)
信息框 (ints.p, ints.b, , )
易语言DLL公开程序中无法自定义数据类型解决办法

 文章源自楠竹林-https://www.nanzl.com/archives/1566

 文章源自楠竹林-https://www.nanzl.com/archives/1566

 文章源自楠竹林-https://www.nanzl.com/archives/1566 文章源自楠竹林-https://www.nanzl.com/archives/1566

yx