易语言利用控件+命令制作一个简单的计算器

yx 技术探讨易语言利用控件+命令制作一个简单的计算器已关闭评论92,439字数 246阅读0分49秒阅读模式

计算器,这算是一个初级例程,也是初学者必做的一道题目。他能让你初步认识到控件于控件之间的搭配与使用,还能初步理解命令的使用。

易语言利用控件+命令制作一个简单的计算器文章源自楠竹林-https://www.nanzl.com/archives/531

部分代码

.版本 2

.局部变量 运算结果, 双精度小数型

最后内容 = 到小数 (编辑框_运算内容.内容)
.判断开始 (运算方式 = “+”)
    运算结果 = 运算内容 + 最后内容
.判断 (运算方式 = “-”)
    运算结果 = 运算内容 - 最后内容
.判断 (运算方式 = “*”)
    运算结果 = 运算内容 × 最后内容
.判断 (运算方式 = “/”)
    运算结果 = 运算内容 ÷ 最后内容
.默认

.判断结束
编辑框_运算内容.内容 = 到文本 (运算结果)

下载信息 源码名称: 计算器
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/531文章源自楠竹林-https://www.nanzl.com/archives/531
yx