易语言利用控件+命令制作一个简单的计算器

yx 2018-08-1620:53:07易语言利用控件+命令制作一个简单的计算器已关闭评论94.1K阅读0分49秒

计算器,这算是一个初级例程,也是初学者必做的一道题目。他能让你初步认识到控件于控件之间的搭配与使用,还能初步理解命令的使用。

易语言利用控件+命令制作一个简单的计算器

部分代码

.版本 2

.局部变量 运算结果, 双精度小数型

最后内容 = 到小数 (编辑框_运算内容.内容)
.判断开始 (运算方式 = “+”)
    运算结果 = 运算内容 + 最后内容
.判断 (运算方式 = “-”)
    运算结果 = 运算内容 - 最后内容
.判断 (运算方式 = “*”)
    运算结果 = 运算内容 × 最后内容
.判断 (运算方式 = “/”)
    运算结果 = 运算内容 ÷ 最后内容
.默认

.判断结束
编辑框_运算内容.内容 = 到文本 (运算结果)

下载信息 源码名称: 计算器 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...