易语言时钟/MP3播放演示,使用两个组件制作一个闹钟

yx 2018-08-1822:14:18易语言时钟/MP3播放演示,使用两个组件制作一个闹钟已关闭评论71.6K阅读0分53秒

时钟的正确使用方式和怎么播放mp3? 在这里编写一个闹钟作为演示程序。

易语言时钟/MP3播放演示,使用两个组件制作一个闹钟

.版本 2

.子程序 _按钮1_被单击

程变_设定时间 = 到时间 (编辑框_时间输入.内容)  ' 将编辑框内容转换为时间
.如果真 (编辑框_时间输入.内容 ≠ “”)
    时钟_定时.时钟周期 = 1000
    返回 ()
.如果真结束
信息框 (“请设定时间”, 0, , )

.子程序 _时钟_定时_周期事件
.局部变量 局_时间, 日期时间型

局_时间 = 取现行时间 ()
.如果真 (局_时间 = 程变_设定时间)
    播放MP3 (1, “1.mp3”)  ' MP3文件必须在目录下,如在其他目录需加上目录路径
    时钟_定时.时钟周期 = 0
    播放时间 ()
下载信息 源码名称: MP3 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...