易语言时钟/MP3播放演示,使用两个组件制作一个闹钟

yx 技术探讨易语言时钟/MP3播放演示,使用两个组件制作一个闹钟已关闭评论69,594字数 267阅读0分53秒阅读模式

时钟的正确使用方式和怎么播放mp3? 在这里编写一个闹钟作为演示程序。

易语言时钟/MP3播放演示,使用两个组件制作一个闹钟文章源自楠竹林-https://www.nanzl.com/archives/538

.版本 2

.子程序 _按钮1_被单击

程变_设定时间 = 到时间 (编辑框_时间输入.内容)  ' 将编辑框内容转换为时间
.如果真 (编辑框_时间输入.内容 ≠ “”)
    时钟_定时.时钟周期 = 1000
    返回 ()
.如果真结束
信息框 (“请设定时间”, 0, , )

.子程序 _时钟_定时_周期事件
.局部变量 局_时间, 日期时间型

局_时间 = 取现行时间 ()
.如果真 (局_时间 = 程变_设定时间)
    播放MP3 (1, “1.mp3”)  ' MP3文件必须在目录下,如在其他目录需加上目录路径
    时钟_定时.时钟周期 = 0
    播放时间 ()
下载信息 源码名称: MP3
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/538文章源自楠竹林-https://www.nanzl.com/archives/538
yx