易语言数组操作/简易学生成绩系统/演示数组操作与使用

yx 技术探讨易语言数组操作/简易学生成绩系统/演示数组操作与使用已关闭评论70,596字数 752阅读2分30秒阅读模式

数组操作可谓简单也可谓复杂,熟练掌握数组可以减少许多不必要的代码量。

易语言数组操作/简易学生成绩系统/演示数组操作与使用文章源自楠竹林-https://www.nanzl.com/archives/545

.版本 2

' 该源码例程来自亦行(YX)博客,由yx编写发布。www.yxblog.cn。转载需注明来源。谢谢

程集_序号 = 程集_序号 + 1
加入成员 (程集_学生, 编辑框_学生.内容)
加入成员 (程集_成绩, 到整数 (编辑框_成绩.内容))

' 以下两种写法都是可以的
' 编辑框_显示.加入文本 (“序号:” + 到文本 (程集_序号) + “  ”, “学生:” + 编辑框_学生.内容 + “  ”, “成绩:” + 编辑框_成绩.内容, #换行符)
编辑框_显示.加入文本 (“序号:” + 到文本 (程集_序号) + “  ”, “学生:” + 程集_学生 [程集_序号] + “  ”, “成绩:” + 到文本 (程集_成绩 [程集_序号]), #换行符)

.子程序 _按钮_删除_被单击


' 删除成员需提供序号
删除成员 (程集_学生, 到整数 (编辑框_序号.内容), )
删除成员 (程集_成绩, 到整数 (编辑框_序号.内容), )


.子程序 _按钮_清空_被单击


清除数组 (程集_学生)
清除数组 (程集_成绩)


.子程序 _按钮_平均数_被单击
.局部变量 数组成员, 整数型
.局部变量 成绩总和, 整数型
.局部变量 记录变量, 整数型

' 提供两种写法,可自行参考

数组成员 = 取数组成员数 (程集_成绩)
.计次循环首 (数组成员, 记录变量)
    成绩总和 = 成绩总和 + 程集_成绩 [记录变量]
.计次循环尾 ()
编辑框_显示.加入文本 (“当前存在的平均成绩为:”, 到文本 (成绩总和 ÷ 数组成员))

' 第二种写法

.' 计次循环首 (取数组成员数 (程集_成绩), 记录变量)
    ' 成绩总和 = 成绩总和 + 程集_成绩 [记录变量]
.' 计次循环尾 ()
' 记录变量 = 记录变量 - 1
' 编辑框_显示.加入文本 (“当前存在的平均成绩为:”, 到文本 (成绩总和 ÷ 记录变量))

‘这里提供了完整的代码,可自行复制到易语言中查看。也可以下载例程’
下载信息 源码名称: 数组操作
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/545文章源自楠竹林-https://www.nanzl.com/archives/545