易语言数组操作/简易学生成绩系统/演示数组操作与使用

yx 2018-08-1919:06:01易语言数组操作/简易学生成绩系统/演示数组操作与使用已关闭评论72.1K阅读2分30秒

数组操作可谓简单也可谓复杂,熟练掌握数组可以减少许多不必要的代码量。

易语言数组操作/简易学生成绩系统/演示数组操作与使用

.版本 2

' 该源码例程来自亦行(YX)博客,由yx编写发布。www.yxblog.cn。转载需注明来源。谢谢

程集_序号 = 程集_序号 + 1
加入成员 (程集_学生, 编辑框_学生.内容)
加入成员 (程集_成绩, 到整数 (编辑框_成绩.内容))

' 以下两种写法都是可以的
' 编辑框_显示.加入文本 (“序号:” + 到文本 (程集_序号) + “  ”, “学生:” + 编辑框_学生.内容 + “  ”, “成绩:” + 编辑框_成绩.内容, #换行符)
编辑框_显示.加入文本 (“序号:” + 到文本 (程集_序号) + “  ”, “学生:” + 程集_学生 [程集_序号] + “  ”, “成绩:” + 到文本 (程集_成绩 [程集_序号]), #换行符)

.子程序 _按钮_删除_被单击


' 删除成员需提供序号
删除成员 (程集_学生, 到整数 (编辑框_序号.内容), )
删除成员 (程集_成绩, 到整数 (编辑框_序号.内容), )


.子程序 _按钮_清空_被单击


清除数组 (程集_学生)
清除数组 (程集_成绩)


.子程序 _按钮_平均数_被单击
.局部变量 数组成员, 整数型
.局部变量 成绩总和, 整数型
.局部变量 记录变量, 整数型

' 提供两种写法,可自行参考

数组成员 = 取数组成员数 (程集_成绩)
.计次循环首 (数组成员, 记录变量)
    成绩总和 = 成绩总和 + 程集_成绩 [记录变量]
.计次循环尾 ()
编辑框_显示.加入文本 (“当前存在的平均成绩为:”, 到文本 (成绩总和 ÷ 数组成员))

' 第二种写法

.' 计次循环首 (取数组成员数 (程集_成绩), 记录变量)
    ' 成绩总和 = 成绩总和 + 程集_成绩 [记录变量]
.' 计次循环尾 ()
' 记录变量 = 记录变量 - 1
' 编辑框_显示.加入文本 (“当前存在的平均成绩为:”, 到文本 (成绩总和 ÷ 记录变量))

‘这里提供了完整的代码,可自行复制到易语言中查看。也可以下载例程’
下载信息 源码名称: 数组操作 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...