易语言简易文件查找程序(寻找文本/子程序(功能/命令)交互/列表框演示)

yx 技术探讨易语言简易文件查找程序(寻找文本/子程序(功能/命令)交互/列表框演示)已关闭评论128,038字数 587阅读1分57秒阅读模式

对于寻找文本,子程序与子程序之间的交互(不如说是功能与功能之间的交叉使用/又或者说是一个命令),列表框的使用。我编写简易的文件查找例程来进行演示。

易语言简易文件查找程序(寻找文本/子程序(功能/命令)交互/列表框演示)文章源自楠竹林-https://www.nanzl.com/archives/548

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮_查找_被单击

' 该源码例程来自亦行(yx)博客,由yx编写完成。www.yxblog.cn。如有转载请注明来源。
功能_查找文件 (编辑框_目录.内容)


.子程序 功能_查找文件
.参数 路径, 文本型
.局部变量 当前文件名, 文本型

当前文件名 = 寻找文件 (路径 + “*.*”, )  ' * 为通配符  *.exe 即代表寻找该目录下所有exe文件 *.*即代表查找所有格式文件
' 当前文件名 = 寻找文件 (编辑框_目录.内容 + “*.*”, #子目录) 查找目录时‘输出“.”代表当前目录  输出“..”代表上级目录
.判断循环首 (当前文件名 ≠ “”)
    当前文件名 = 寻找文件 (, )  ' 这里不加参数进行寻找是为了继承上面的寻找文件继续寻找“不加参数继续寻找”
    功能_加入列表框 (当前文件名, 取文件时间 (路径 + 当前文件名), 四舍五入 (取文件尺寸 (路径 + 当前文件名) ÷ 1024, 1))
.判断循环尾 ()



.子程序 功能_加入列表框
.参数 文件名, 文本型
.参数 日期, 日期时间型
.参数 大小, 双精度小数型

列表框1.加入项目 (“文件名:” + 文件名 + “ | 时间:” + 到文本 (日期) + “ | 大小:” + 到文本 (大小) + “KB”, )

‘源码复制至易语言中即可,也可以下载例程’
下载信息 源码名称: 文件查找
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/548文章源自楠竹林-https://www.nanzl.com/archives/548