易语言文件查找 – 子程序属性/子程序递归/超级列表框演示

yx 2018-08-2020:12:11易语言文件查找 – 子程序属性/子程序递归/超级列表框演示已关闭评论89K阅读5分3秒

此文件查找不同于之前亦行发布的文件查找,此程序主要用于演示子程序属性/子程序递归/超级列表框的使用。搜寻目录以及目录下的所有目录内文件

易语言文件查找 – 子程序属性/子程序递归/超级列表框演示

.版本 2
.支持库 iext

.子程序 _按钮_查找_被单击

' 该源码例程来自亦行(yx)博客,由yx编写发布。如转载请注明来源(www.yxblog.cn)
子程序_文件查找 (编辑框_目录.内容)

.子程序 子程序_文件查找
.参数 查找目录, 文本型, 可空
.局部变量 文件名, 文本型
.局部变量 索引, 整数型
.局部变量 尺寸计算, 双精度小数型

.如果真 (是否为空 (查找目录) = 真)
    查找目录 = “C:\Windows\”
.如果真结束
.如果真 (取文本右边 (查找目录, 1) ≠ “\”)
    查找目录 = 查找目录 + “\”
.如果真结束

文件名 = 寻找文件 (查找目录 + “*.*”, 1 + 2 + 4 + 16 + 32)

.判断循环首 (文件名 ≠ “”)
    .如果真 (文件名 = “”)
        文件名 = 寻找文件 (, 1 + 2 + 4 + 16 + 32)  ' 注明:继续寻找
        到循环尾 ()
    .如果真结束
    .如果真 (文件名 = “.” 或 文件名 = “..”)  ' 注明:不输出
        文件名 = 寻找文件 (, 1 + 2 + 4 + 16 + 32)  ' 注明:继续寻找
        到循环尾 ()
    .如果真结束
    .如果真 (取文件属性 (查找目录 + 文件名) = #子目录)  ' 注明:找到目录进入目录继续查找
        子程序_文件查找 (查找目录 + 文件名)  ' 注明:找到目录进入目录将目录地址传入继续查找目录内的文件,完毕到循环尾继续查找下一个目录
        文件名 = 寻找文件 (, 1 + 2 + 4 + 16 + 32)  ' 注明:继续寻找
        到循环尾 ()
    .如果真结束
    索引 = 超级列表框_显示.插入表项 (索引, , , , , )  ' 注明:插入表项索引
    超级列表框_显示.置标题 (索引, 0, 文件名)
    超级列表框_显示.置标题 (索引, 1, 到文本 (取文件时间 (查找目录 + 文件名)))
    ' 尺寸计算 = 取文件尺寸 (查找目录 + 文件名) ÷ 1024
    超级列表框_显示.置标题 (索引, 2, 到文本 (四舍五入 (取文件尺寸 (查找目录 + 文件名) ÷ 1024, 1)) + “KB”)
    文件名 = 寻找文件 (, 1 + 2 + 4 + 16 + 32)
.判断循环尾 ()

子程序属性演示

.版本 2

.子程序 _按钮1_被单击
.局部变量 整数参数, 整数型
.局部变量 文本参数, 文本型

整数参数 = 1
文本参数 = “文本参数”
输出调试文本 (文本参数)
自定义的子程序 (整数参数, 文本参数)
输出调试文本 (文本参数)

.子程序 自定义的子程序
.参数 整数参数, 整数型, 参考 可空, 参考:如果选中参考且提供的参数为变量的时候,即可以在本子程序内修改该变量的值并返回
.参数 文本参数, 文本型, , 参考:如果所传递过来的参数数据为数组、用户定义数据类型、库定义数据类型、文本型、字节集型数据,则无论此属性是否为真,都将传递指针

' 参考的使用: 设置系统为当前子程序参数传递数据时是否为传递指向数据的指针。如果所传递过来的参数数据为数组、用户定义数据类型、库定义数据类型、文本型、字节集型数据,则无论此属性是否为真,都将传递指针。如果所传递过来数据的类型与相应位置处参数的数据类型不一致但可以相互转换,譬如将“整数型”数据传递到“小数型”的参数中,则在数据被实际传递前,系统将首先自动将“整数型”数据转换为“小数型” 数据,然后再进行传递。因此在这种情况下,即使本属性为真,系统也无法传递指向原数据的指针,只能传递数据本身。如果系统将数据指针成功地传递过来,那么在子程序中对此参数内容的更改将会相应地反映到调用子程序时所提供的参数数据上。

.' 如果真 (是否为空 (整数参数) = 真)  ' 返回一个逻辑值,指出在调用子程序时是否为指定参数提供了数据(该参数必定有“可空”标志),如未提供,返回真,否则返回假。
    ' 整数参数 = 100
.如果真结束

整数参数 = 100
文本参数 = “易语言程序”
' 输出调试文本 (整数参数)

下载信息 源码名称: 子程序递归 源码适用: 易语言
下载地址
继续阅读
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...