易语言文件查找 – 树形框/浏览文件夹/状态栏演示

yx 2018-08-2101:02:07易语言文件查找 – 树形框/浏览文件夹/状态栏演示已关闭评论141.4K阅读4分33秒

文件查找演示程序写到这里完善的也就差不多了,这里主要是演示了树型框/状态栏,以及浏览文件夹命令的使用

易语言文件查找 – 树形框/浏览文件夹/状态栏演示

.版本 2
.支持库 iext
.支持库 shell
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 程集_目录, 文本型

.子程序 _按钮_查找_被单击

' 该源码例程来自亦行(yx)博客,由yx编写发布。如有转载请注明来源www.yxblog.cn
树型框_目录结构.清空 ()
.判断开始 (按钮_查找.标题 = “查找目录”)
    编辑框_查找目录.内容 = 浏览文件夹 (“易语言”, 假)
    按钮_查找.标题 = “开始查找”
.判断 (按钮_查找.标题 = “开始查找”)
    程序_文件查找 (编辑框_查找目录.内容, )
.默认

.判断结束


.子程序 程序_文件查找
.参数 查找目录, 文本型, 可空
.参数 父项目索引, 整数型, 可空
.局部变量 文件名, 文本型
.局部变量 临时_项目索引, 整数型

.如果真 (是否为空 (查找目录) = 真)
    查找目录 = “C:\Windows\”
.如果真结束
.如果真 (取文本右边 (查找目录, 1) ≠ “\”)
    查找目录 = 查找目录 + “\”
.如果真结束
.如果真 (是否为空 (父项目索引) = 真)  ' 目的是为了检查是否传入树形框父项目索引
    父项目索引 = -1
.如果真结束

程集_目录 = 查找目录
文件名 = 寻找文件 (查找目录 + “*.*”, 1 + 2 + 4 + 16 + 32)
状态条1.置文本 (0, “查找进程:” + 查找目录 + 文件名)
' 调试输出 (“查找进程:” + 查找目录 + 文件名)
.判断循环首 (文件名 ≠ “”)

    .如果真 (文件名 = “.” 或 文件名 = “..”)
        文件名 = 寻找文件 (, 1 + 2 + 4 + 16 + 32)
        到循环尾 ()
    .如果真结束

    临时_项目索引 = 树型框_目录结构.加入项目 (父项目索引, 文件名, , , , , )  ' 注明:临时项目索引记录

    .如果真 (取文件属性 (查找目录 + 文件名) = #子目录)
        程序_文件查找 (查找目录 + 文件名, 临时_项目索引)
        文件名 = 寻找文件 (, 1 + 2 + 4 + 16 + 32)
        到循环尾 ()
    .如果真结束

    文件名 = 寻找文件 (, 1 + 2 + 4 + 16 + 32)
    处理事件 ()
.判断循环尾 ()
状态条1.置文本 (0, “查找进程:” + “查找完毕”)

.子程序 _树型框_目录结构_项目被选择
.参数 选择方式, 整数型
.局部变量 临时目录索引, 整数型
.局部变量 临时目录, 文本型
.局部变量 文件名, 文本型

临时目录索引 = 树型框_目录结构.取父项目 (树型框_目录结构.现行选中项)
临时目录 = 编辑框_查找目录.内容 + “\” + 树型框_目录结构.取项目文本 (临时目录索引)
' 调试输出 (到文本 (临时目录索引) + #换行符 + 临时目录)
.如果真 (临时目录索引 = -1)
    临时目录索引 = 树型框_目录结构.现行选中项
    临时目录 = 编辑框_查找目录.内容 + “\” + 树型框_目录结构.取项目文本 (临时目录索引)
.如果真结束

' 调试输出 (到文本 (临时目录索引) + #换行符 + 临时目录)

编辑框_信息显示.内容 = “”
.如果真 (选择方式 = 1)
    文件名 = “\” + 树型框_目录结构.取项目文本 (树型框_目录结构.现行选中项)
    调试输出 (临时目录 + 文件名)
    编辑框_信息显示.加入文本 (“名称:” + 树型框_目录结构.取项目文本 (树型框_目录结构.现行选中项), #换行符, “时间:” + 到文本 (取文件时间 (临时目录 + 文件名)), #换行符, “尺寸:” + 到文本 (四舍五入 (取文件尺寸 (临时目录 + 文件名) ÷ 1024, 2)), #换行符)
.如果真结束
下载信息 源码名称: 树形框/浏览文件夹 源码适用: 易语言
下载地址 查看演示
继续阅读
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...