易语言用精易模块编写一个任务管理器

yx 源码例程1 125,629字数 963阅读3分12秒阅读模式

用精易模块模仿系统任务管理器编写一个自己的任务管理器

易语言用精易模块编写一个任务管理器文章源自楠竹林-https://www.nanzl.com/archives/563

.版本 2
.支持库 iext

.子程序 程序_枚举进程至列表框
.参数 是否输出系统进程, 逻辑型, 可空
.局部变量 进程名数组, 文本型, , "0"
.局部变量 进程ID数组, 整数型, , "0"
.局部变量 数组记录, 整数型
.局部变量 索引, 整数型

' 该源码例程来自亦行(yx)博客,由yx编写发布。如需转载请注明来源(www.yxblog.cn)
超级列表框1.全部删除 ()
进程_枚举 (进程名数组, 进程ID数组)
.如果真 (是否为空 (是否输出系统进程) = 真)
    是否输出系统进程 = 假
.如果真结束

.计次循环首 (取数组成员数 (进程名数组), 数组记录)

    .如果真 (进程_取用户名 (进程ID数组 [数组记录]) = “”)
        .判断开始 (是否输出系统进程 = 假)
            到循环尾 ()
        .默认

        .判断结束

    .如果真结束
    .如果真 (进程ID数组 [数组记录] ≤ 4)
        到循环尾 ()
    .如果真结束
    索引 = 超级列表框1.插入表项 (, 进程名数组 [数组记录], , , , )
    超级列表框1.置标题 (索引, 2, 进程_取用户名 (进程ID数组 [数组记录]))
    超级列表框1.置标题 (索引, 3, 进程_内存使用 (进程ID数组 [数组记录]))
    超级列表框1.置标题 (索引, 1, 到文本 (进程ID数组 [数组记录]))
    超级列表框1.置标题 (索引, 4, 进程_取程序路径 (进程ID数组 [数组记录]))
.计次循环尾 ()


.子程序 __启动窗口_创建完毕

程序_枚举进程至列表框 ()


.子程序 _显示系统进程_被选择

.如果真 (显示系统进程.选中 = 假)
    显示系统进程.选中 = 真
    程序_枚举进程至列表框 (真)
.如果真结束
.如果真 (显示系统进程.选中 = 真)
    显示系统进程.选中 = 假
    程序_枚举进程至列表框 (假)
.如果真结束


.子程序 _自动刷新进程_被选择

.如果真 (自动刷新进程.选中 = 真)
    自动刷新进程.选中 = 假
    时钟1.时钟周期 = 0
.如果真结束
.如果真 (自动刷新进程.选中 = 假)
    时钟1.时钟周期 = 10000
    自动刷新进程.选中 = 真
.如果真结束


.子程序 _时钟1_周期事件

_显示系统进程_被选择 ()


.子程序 _程序保持最前_被选择

.如果真 (程序保持最前.选中 = 真)
    _启动窗口.总在最前 = 假
    程序保持最前.选中 = 假
.如果真结束
.如果真 (程序保持最前.选中 = 假)
    _启动窗口.总在最前 = 真
    程序保持最前.选中 = 真
.如果真结束


.子程序 _退出任务_被选择

结束 ()

下载信息 源码名称: 任务管理器 源码适用: 易语言 WIN
最近更新2019-7-12
下载地址 查看演示
文章源自楠竹林-https://www.nanzl.com/archives/563文章源自楠竹林-https://www.nanzl.com/archives/563
继续阅读
yx