易语言业务叫号系统/对数组应用演示

yx 2018-08-2114:36:13易语言业务叫号系统/对数组应用演示已关闭评论65.3K阅读2分0秒

或多或少对于数组的使用还是有一些迷糊,业务叫号系统演示了数组的应用

易语言业务叫号系统/对数组应用演示

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 程序集_号码数组, 整数型, , "0"
.程序集变量 程序集_当前号码, 整数型

.子程序 _按钮_取号_被单击

' 该源码例程来自亦行(yx)博客,由yx编写发布,如由转载,请注明来源www.yxblog.cn
程序集_当前号码 = 程序集_当前号码 + 1
加入成员 (程序集_号码数组, 程序集_当前号码)
编辑框_输出.加入文本 (“您取的号码为:” + 到文本 (程序集_当前号码), #换行符)

.子程序 _按钮_叫号_被单击
.局部变量 临时_当前号码, 整数型

.如果真 (取数组成员数 (程序集_号码数组) > 0)
    临时_当前号码 = 程序集_号码数组 [1]
    删除成员 (程序集_号码数组, 1, 1)
    编辑框_输出.加入文本 (“开始处理:” + 到文本 (临时_当前号码) + “.”, #换行符)
.如果真结束


.子程序 _按钮_查看任务_被单击

编辑框_输出.加入文本 (“开始列举所有任务:”, #换行符)
编辑框_输出.加入文本 (“正等待人数:” + 到文本 (取数组成员数 (程序集_号码数组)), #换行符)
编辑框_输出.加入文本 (“所有任务列举完毕”, #换行符)



.子程序 _按钮1_被单击

清除数组 (程序集_号码数组)
编辑框_输出.内容 = “”
编辑框_输出.内容 = “当前所有任务清除完毕” + #换行符

.子程序 _按钮_取号1_被单击

编辑框_输出.加入文本 (“处理完毕”, #换行符)

下载信息 源码名称: 业务叫号系统 源码适用: 易语言 WIN
下载地址 查看演示
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...