易语言业务叫号系统/对数组应用演示

yx 技术探讨易语言业务叫号系统/对数组应用演示已关闭评论63,768字数 601阅读2分0秒阅读模式

或多或少对于数组的使用还是有一些迷糊,业务叫号系统演示了数组的应用

易语言业务叫号系统/对数组应用演示文章源自楠竹林-https://www.nanzl.com/archives/566

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 程序集_号码数组, 整数型, , "0"
.程序集变量 程序集_当前号码, 整数型

.子程序 _按钮_取号_被单击

' 该源码例程来自亦行(yx)博客,由yx编写发布,如由转载,请注明来源www.yxblog.cn
程序集_当前号码 = 程序集_当前号码 + 1
加入成员 (程序集_号码数组, 程序集_当前号码)
编辑框_输出.加入文本 (“您取的号码为:” + 到文本 (程序集_当前号码), #换行符)

.子程序 _按钮_叫号_被单击
.局部变量 临时_当前号码, 整数型

.如果真 (取数组成员数 (程序集_号码数组) > 0)
    临时_当前号码 = 程序集_号码数组 [1]
    删除成员 (程序集_号码数组, 1, 1)
    编辑框_输出.加入文本 (“开始处理:” + 到文本 (临时_当前号码) + “.”, #换行符)
.如果真结束


.子程序 _按钮_查看任务_被单击

编辑框_输出.加入文本 (“开始列举所有任务:”, #换行符)
编辑框_输出.加入文本 (“正等待人数:” + 到文本 (取数组成员数 (程序集_号码数组)), #换行符)
编辑框_输出.加入文本 (“所有任务列举完毕”, #换行符)



.子程序 _按钮1_被单击

清除数组 (程序集_号码数组)
编辑框_输出.内容 = “”
编辑框_输出.内容 = “当前所有任务清除完毕” + #换行符

.子程序 _按钮_取号1_被单击

编辑框_输出.加入文本 (“处理完毕”, #换行符)

下载信息 源码名称: 业务叫号系统
最近更新2023-1-12
下载地址 查看演示
文章源自楠竹林-https://www.nanzl.com/archives/566文章源自楠竹林-https://www.nanzl.com/archives/566
yx