易语言交通信号灯系统,模拟简单的动画效果

yx 2018-08-2119:50:26易语言交通信号灯系统,模拟简单的动画效果已关闭评论84.3K阅读2分6秒

一个简单的交通信号灯系统,可以自己下载来试着改写一下

易语言交通信号灯系统,模拟简单的动画效果

.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 显示值, 整数型, , , 1 等于红  2 等于黄 3 等于绿
.程序集变量 显示时间, 整数型

.子程序 _按钮1_被单击

' 该源码例程来自亦行(yx)博客,由yx编写发布,如转载请注明来源(www.yxblog.cn)
显示值 = 1
显示时间 = 10
时钟_控制枢纽.时钟周期 = 1000

.子程序 _时钟_控制枢纽_周期事件

.如果真 (显示值 = 1)
    显示时间 = 显示时间 - 1
    透明标签_红.标题 = 到文本 (显示时间)
    .如果真 (显示时间 = 0)
        显示值 = 2
        显示时间 = 6
    .如果真结束

.如果真结束
.如果真 (显示值 = 2)
    显示时间 = 显示时间 - 1
    透明标签_黄.标题 = 到文本 (显示时间)
    .如果真 (显示时间 = 0)
        显示值 = 3
        显示时间 = 16
    .如果真结束

.如果真结束
.如果真 (显示值 = 3)
    显示时间 = 显示时间 - 1
    透明标签_绿.标题 = 到文本 (显示时间)
    .如果真 (显示时间 = 0)
        显示值 = 1
        显示时间 = 10
    .如果真结束

.如果真结束
程序_系统显示流程 (显示值)

.子程序 程序_系统显示流程
.参数 显示值, 整数型

.判断开始 (显示值 = 1)
    外形框_红.填充颜色 = #红色
    外形框_黄.填充颜色 = #透明
    外形框_绿.填充颜色 = #透明
.判断 (显示值 = 2)
    外形框_红.填充颜色 = #透明
    外形框_黄.填充颜色 = #黄色
    外形框_绿.填充颜色 = #透明
.判断 (显示值 = 3)
    外形框_红.填充颜色 = #透明
    外形框_黄.填充颜色 = #透明
    外形框_绿.填充颜色 = #绿色
.默认

.判断结束
下载信息 源码名称: 模拟红绿灯效果 源码适用: 易语言 WIN
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...