易语言交通信号灯系统,模拟简单的动画效果

yx 技术探讨易语言交通信号灯系统,模拟简单的动画效果已关闭评论82,631字数 633阅读2分6秒阅读模式

一个简单的交通信号灯系统,可以自己下载来试着改写一下

易语言交通信号灯系统,模拟简单的动画效果文章源自楠竹林-https://www.nanzl.com/archives/569

.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 显示值, 整数型, , , 1 等于红  2 等于黄 3 等于绿
.程序集变量 显示时间, 整数型

.子程序 _按钮1_被单击

' 该源码例程来自亦行(yx)博客,由yx编写发布,如转载请注明来源(www.yxblog.cn)
显示值 = 1
显示时间 = 10
时钟_控制枢纽.时钟周期 = 1000

.子程序 _时钟_控制枢纽_周期事件

.如果真 (显示值 = 1)
    显示时间 = 显示时间 - 1
    透明标签_红.标题 = 到文本 (显示时间)
    .如果真 (显示时间 = 0)
        显示值 = 2
        显示时间 = 6
    .如果真结束

.如果真结束
.如果真 (显示值 = 2)
    显示时间 = 显示时间 - 1
    透明标签_黄.标题 = 到文本 (显示时间)
    .如果真 (显示时间 = 0)
        显示值 = 3
        显示时间 = 16
    .如果真结束

.如果真结束
.如果真 (显示值 = 3)
    显示时间 = 显示时间 - 1
    透明标签_绿.标题 = 到文本 (显示时间)
    .如果真 (显示时间 = 0)
        显示值 = 1
        显示时间 = 10
    .如果真结束

.如果真结束
程序_系统显示流程 (显示值)

.子程序 程序_系统显示流程
.参数 显示值, 整数型

.判断开始 (显示值 = 1)
    外形框_红.填充颜色 = #红色
    外形框_黄.填充颜色 = #透明
    外形框_绿.填充颜色 = #透明
.判断 (显示值 = 2)
    外形框_红.填充颜色 = #透明
    外形框_黄.填充颜色 = #黄色
    外形框_绿.填充颜色 = #透明
.判断 (显示值 = 3)
    外形框_红.填充颜色 = #透明
    外形框_黄.填充颜色 = #透明
    外形框_绿.填充颜色 = #绿色
.默认

.判断结束
下载信息 源码名称: 模拟红绿灯效果
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/569文章源自楠竹林-https://www.nanzl.com/archives/569
yx