文本分割并加入列表框例程

yx 源码例程文本分割并加入列表框例程已关闭评论86,906字数 396阅读1分19秒阅读模式

文本分割并加入列表框例程

文本分割并加入列表框例程文章源自楠竹林-https://www.nanzl.com/archives/572

.版本 2
.支持库 spec
.支持库 iext

.子程序 __启动窗口_创建完毕
.局部变量 内容, 文本型
' 该源码例程来自亦行(yx),由yx编写发布www.yxblog.cn
内容 = 到文本 (读入文件 (取当前目录 () + “\文本信息.txt”))
文本处理 (内容)
调试输出 (内容)

.子程序 文本处理
.参数 文本内容, 文本型
.局部变量 处理内容, 文本型, , "0"
.局部变量 处理内容2, 文本型, , "0"
.局部变量 成员记录, 整数型
.局部变量 索引, 整数型

处理内容 = 分割文本 (文本内容, #换行符, )
调试输出 (处理内容)
.计次循环首 (取数组成员数 (处理内容), 成员记录)
    处理内容2 = 分割文本 (处理内容 [成员记录], “|”, 2)
    索引 = 超级列表框1.插入表项 (-1, 到文本 (成员记录), , , , )
    超级列表框1.置标题 (索引, 1, 处理内容2 [1])
    超级列表框1.置标题 (索引, 2, 处理内容2 [2])
.计次循环尾 ()
下载信息 源码名称: 文本分割 源码适用: 易语言
最近更新2019-7-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/572文章源自楠竹林-https://www.nanzl.com/archives/572
yx