文本分割并加入列表框例程

yx 2018-08-2122:19:23文本分割并加入列表框例程已关闭评论88.7K阅读1分19秒

文本分割并加入列表框例程

文本分割并加入列表框例程

.版本 2
.支持库 spec
.支持库 iext

.子程序 __启动窗口_创建完毕
.局部变量 内容, 文本型
' 该源码例程来自亦行(yx),由yx编写发布www.yxblog.cn
内容 = 到文本 (读入文件 (取当前目录 () + “\文本信息.txt”))
文本处理 (内容)
调试输出 (内容)

.子程序 文本处理
.参数 文本内容, 文本型
.局部变量 处理内容, 文本型, , "0"
.局部变量 处理内容2, 文本型, , "0"
.局部变量 成员记录, 整数型
.局部变量 索引, 整数型

处理内容 = 分割文本 (文本内容, #换行符, )
调试输出 (处理内容)
.计次循环首 (取数组成员数 (处理内容), 成员记录)
    处理内容2 = 分割文本 (处理内容 [成员记录], “|”, 2)
    索引 = 超级列表框1.插入表项 (-1, 到文本 (成员记录), , , , )
    超级列表框1.置标题 (索引, 1, 处理内容2 [1])
    超级列表框1.置标题 (索引, 2, 处理内容2 [2])
.计次循环尾 ()
下载信息 源码名称: 文本分割 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...