用精易模块编写一个简单的精易客户端

yx 2018-08-2215:12:11用精易模块编写一个简单的精易客户端已关闭评论51.7K阅读1分52秒

对于一些初学者来说,这个编写起来比较困难。

用精易模块编写一个简单的精易客户端

.版本 2
.支持库 iext
.支持库 HtmlView

.子程序 __启动窗口_创建完毕

' 该源码例程来自亦行(yx)博客,由yx编写发布,如有转载请注明来源www.yxblog.cn
功能_板块处理显示 ()
载入 (窗口1, , 假)
窗口1.可视 = 假
' 功能_帖子处理显示 (“https://bbs.125.la/forum-121-1.html”)

.子程序 功能_板块处理显示
.局部变量 板块网页内容, 文本型
.局部变量 取出中间代码, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 索引, 整数型

板块网页内容 = 网页_访问S (“https://bbs.125.la/”, 0, , , , , , , , , )
板块网页内容 = 文本_取出中间文本 (板块网页内容, “会员互动区”, “在线会员”, , )
文本_取中间_批量 (板块网页内容, “
”, “
”, 取出中间代码, , , , , , , ) .计次循环首 (取数组成员数 (取出中间代码), i) 输出调试文本 (取出中间代码 [i]) 索引 = 超级列表框_显示.插入表项 (-1, 到文本 (i), , , , ) 超级列表框_显示.置标题 (索引, 1, 文本_取出中间文本 (取出中间代码 [i], #引号 + “>”, “”, , )) 超级列表框_显示.置标题 (索引, 2, “https://bbs.125.la” + 文本_取出中间文本 (取出中间代码 [i], “[”, 取出代码, , , , , , , ) .计次循环首 (取数组成员数 (取出代码), i) ' 输出调试文本 (取出代码 [i]) 索引 = 超级列表框_显示2.插入表项 (-1, 到文本 (i), , , , ) 超级列表框_显示2.置标题 (索引, 1, 文本_取出中间文本 (取出代码 [i], “s xst” + #引号 + “>”, “”, , )) 超级列表框_显示2.置标题 (索引, 2, “https://bbs.125.la” + 文本_取出中间文本 (取出代码 [i], “
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...