TIM自动消息小工具(WinApi操作模块+精易模块)

yx 2018-08-2419:32:17TIM自动消息小工具(WinApi操作模块+精易模块)已关闭评论103.9K阅读4分13秒

写的比较杂乱,勿见怪

TIM自动消息小工具(WinApi操作模块+精易模块)

.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 程集_文本内容, 文本型
.程序集变量 句柄信息数组_, 整数型, , "0"

.子程序 查找父窗口句柄, 整数型, , 每查找到句柄一次就调用一次
.参数 找出的句柄, 整数型
.参数 附加, 整数型
.局部变量 临时_类名, 文本型
.局部变量 RECT, RECT
.局部变量 临时_标题, 文本型
.局部变量 临时_前台, 整数型


API函数_取窗口类名 (找出的句柄, 临时_类名)
' 调试输出 (找出的句柄, 临时_类名)
.如果真 (临时_类名 = “TXGuiFoundation”)
    API函数_取窗口标题 (找出的句柄, 临时_标题)
    .如果真 (临时_标题 ≠ “” 且 临时_标题 ≠ “TXMenuWindow” 且 临时_标题 ≠ “TIM”)
        API函数_取窗口位置 (找出的句柄, RECT)
        ' 调试输出 (找出的句柄, 临时_类名, 临时_标题, RECT.左边, RECT.顶边, RECT.右边, RECT.底边)
        临时_前台 = API函数_取前台窗口 ()
        ' 调试输出 (临时_前台)
        加入成员 (句柄信息数组_, 找出的句柄)
        .如果真 (临时_前台 = 找出的句柄)
            ' 调试输出 (找出的句柄, 临时_类名, 临时_标题, RECT.左边, RECT.顶边, RECT.右边, RECT.底边)
            窗口_窗口吸附 (_启动窗口, 找出的句柄, RECT, 2)
            ' _启动窗口.可视 = 真
        .如果真结束

    .如果真结束

.如果真结束
返回 (找出的句柄)


.子程序 _时钟1_周期事件

API函数_列出父窗口句柄 (&查找父窗口句柄, 100)


.子程序 _按钮1_被单击

程集_文本内容 = 到文本 (读入文件 (编辑框_地址.内容))
分割文本_ ()

.子程序 分割文本_
.局部变量 分割内容, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 索引, 整数型

分割内容 = 分割文本 (程集_文本内容, #换行符, )
.计次循环首 (取数组成员数 (分割内容), i)
    索引 = 超级列表框_显示.插入表项 (-1, 到文本 (i), , , , )
    超级列表框_显示.置标题 (索引, 1, 分割内容 [i])
.计次循环尾 ()


.子程序 _超级列表框_显示_被双击, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

.如果真 (超级列表框_显示.现行选中项 = -1)
    返回 ()
.如果真结束
置剪辑板文本 (超级列表框_显示.取标题 (超级列表框_显示.现行选中项, 1))


.子程序 置托盘



.子程序 __启动窗口_创建完毕

_启动窗口.置托盘图标 (#ICO, “跟随TIM”)
_启动窗口.可视 = 假




.子程序 _时钟2_周期事件

子程序1 ()



.子程序 子程序1
.局部变量 i, 整数型
.局部变量 i1, 整数型
.局部变量 表项数, 整数型

' 输出调试文本 (取数组成员数 (句柄信息数组_))
.计次循环首 (取数组成员数 (句柄信息数组_), i)

    API函数_设置窗口到前台 (句柄信息数组_ [i])
    ' 输出调试文本 (句柄信息数组_ [i])
    ' 表项数 = 超级列表框_显示.取表项数 ()
    置剪辑板文本 (超级列表框_显示.取标题 (i1, 1))
    文本_粘贴 (句柄信息数组_ [i])
    键盘_单击 (13, 1)

.计次循环尾 ()
清除数组 (句柄信息数组_)

下载信息 源码名称: QQ定时消息 源码适用: 易语言 WIN
下载地址
继续阅读
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...