易语言软件QQ群验证源码例程

yx 技术探讨1 161,0801字数 1146阅读3分49秒阅读模式

这是一个QQ群验证源码,自行下载研究吧!源码是我搜集的,我检查过了能用

易语言软件QQ群验证源码例程文章源自楠竹林-https://www.nanzl.com/archives/605

.版本 2
.支持库 HtmlView
.支持库 iext
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 QQ群号, 文本型
.程序集变量 验证中, 逻辑型

.子程序 __启动窗口_创建完毕

' 本源码来自亦行(yx)博客,如需转载请注明来源www.yxblog.cn
网页_清除Cookie (“qun.qzone.qq.com”)
QQ群号 = “123456789”  ' 这里修改成你要验证的QQ群号
超文本浏览框1.地址 = “qun.qzone.qq.com”

.子程序 GTK, 文本型
.参数 skey, 文本型
.局部变量 基值, 整数型
.局部变量 计数, 整数型
.局部变量 长度, 整数型
.局部变量 结果, 整数型

基值 = 5381
计数 = 0
长度 = 取文本长度 (skey)
.判断循环首 (计数 < 长度)
    基值 = 基值 + 左移 (基值, 5) + 取代码 (skey, 计数 + 1)
    计数 = 计数 + 1
.判断循环尾 ()
结果 = 位与 (基值, 2147483647)
返回 (到文本 (结果))

.子程序 _超文本浏览框1_标题被改变

.如果真 (超文本浏览框1.地址 = “http://qun.qzone.qq.com/group” 且 验证中 = 假)
    验证中 = 真
    超文本浏览框1.可视 = 假
    标签1.可视 = 真
    子程序1_QQ ()
.如果真结束


.子程序 子程序1_QQ
.局部变量 Cookie, 文本型
.局部变量 QQ, 文本型
.局部变量 tk, 文本型
.局部变量 返回文本, 文本型

Cookie = 网页_取Cookie (“qun.qzone.qq.com”)
QQ = 文本_取出中间文本 (Cookie, “uin=o”, “; ”)
tk = GTK (文本_取出中间文本 (Cookie, “skey=”, “; ”))
返回文本 = 网页_访问S (“http://qun.qzone.qq.com/cgi-bin/get_group_list?groupcount=4&count=4&callbackFun=_GetGroupPortal&uin=” + QQ + “&g_tk=” + tk + “&ua=Mozilla%2F5.0%20(Windows%20NT%206.1%3B%20WOW64)%20AppleWebKit%2F537.36%20(KHTML%2C%20like%20Gecko)%20Chrome%2F55.0.2883.87%20Safari%2F537.36”, , , Cookie)
返回文本 = 编码_URL编码 (返回文本, 真)
调试输出 (“groupid” + #引号 + “:” + QQ群号)
.判断开始 (寻找文本 (返回文本, QQ群号, , 假) = -1)
    信息框 (“请加入《” + QQ群号 + “》QQ群再使用”, 0, , )
    程序_重启 ()
.默认
    信息框 (“验证成功”, 0, , )
    标签1.标题 = “验证成功!”
.判断结束

文章源自楠竹林-https://www.nanzl.com/archives/605文章源自楠竹林-https://www.nanzl.com/archives/605
继续阅读
yx