易语言软件日志写法例程

yx 2018-08-2720:07:58易语言软件日志写法例程已关闭评论194.8K阅读2分4秒

有一些时候我们调试软件的时候需要记录日志来知道软件的运行情况

易语言软件日志写法例程

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 程集_文件号, 整数型, , , 记录文件号

.子程序 __启动窗口_创建完毕

' 该例程来自亦行(yx)博客,由yx编写发布,如有转载请注明来源www.yxblog.cn
' 打开方式
' 1、#读入:从指定文件读入数据,如果该文件不存在则失败;
' 2、#写出:写出数据到指定文件,如果该文件不存在则失败;
' 3、#读写:从文件中读入数据或者写出数据到文件,如果该文件不存在则失败;
' 4、#重写:写出数据到指定文件。如果该文件不存在则先创建一个新文件,如果已经存在就先清除其中的所有数据;
' 5、#改写:写出数据到指定文件。如果该文件不存在则创建一个新文件,如果已经存在就直接打开;
' 6、#改读:从文件中读入数据或者写出数据到文件。如果该文件不存在则创建一个新文件,如果已经存在就直接打开。

程集_文件号 = 打开文件 (“log.txt”, #改写, )
移到文件尾 (程集_文件号)
写文本行 (程集_文件号, 到文本 (取现行时间 ()) + “===>” + “软件开始运行”)
子程序1 ()

.子程序 子程序1

写文本行 (程集_文件号, 到文本 (取现行时间 ()) + “===>” + “子程序一”)
子程序2 ()

.子程序 子程序2

写文本行 (程集_文件号, 到文本 (取现行时间 ()) + “===>” + “子程序二”)


.子程序 _按钮1_被单击

写文本行 (程集_文件号, 到文本 (取现行时间 ()) + “===>” + 编辑框1.内容)

下载信息 源码名称: 日志 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...