易语言软件日志写法例程

yx 技术探讨易语言软件日志写法例程已关闭评论190,571字数 624阅读2分4秒阅读模式

有一些时候我们调试软件的时候需要记录日志来知道软件的运行情况

易语言软件日志写法例程文章源自楠竹林-https://www.nanzl.com/archives/611

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 程集_文件号, 整数型, , , 记录文件号

.子程序 __启动窗口_创建完毕

' 该例程来自亦行(yx)博客,由yx编写发布,如有转载请注明来源www.yxblog.cn
' 打开方式
' 1、#读入:从指定文件读入数据,如果该文件不存在则失败;
' 2、#写出:写出数据到指定文件,如果该文件不存在则失败;
' 3、#读写:从文件中读入数据或者写出数据到文件,如果该文件不存在则失败;
' 4、#重写:写出数据到指定文件。如果该文件不存在则先创建一个新文件,如果已经存在就先清除其中的所有数据;
' 5、#改写:写出数据到指定文件。如果该文件不存在则创建一个新文件,如果已经存在就直接打开;
' 6、#改读:从文件中读入数据或者写出数据到文件。如果该文件不存在则创建一个新文件,如果已经存在就直接打开。

程集_文件号 = 打开文件 (“log.txt”, #改写, )
移到文件尾 (程集_文件号)
写文本行 (程集_文件号, 到文本 (取现行时间 ()) + “===>” + “软件开始运行”)
子程序1 ()

.子程序 子程序1

写文本行 (程集_文件号, 到文本 (取现行时间 ()) + “===>” + “子程序一”)
子程序2 ()

.子程序 子程序2

写文本行 (程集_文件号, 到文本 (取现行时间 ()) + “===>” + “子程序二”)


.子程序 _按钮1_被单击

写文本行 (程集_文件号, 到文本 (取现行时间 ()) + “===>” + 编辑框1.内容)

下载信息 源码名称: 日志
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/611文章源自楠竹林-https://www.nanzl.com/archives/611
yx