易语言SQL数据库调用例程

易语言SQL数据库调用例程(记录与读取)

易语言SQL数据库调用例程

.版本 2
.支持库 sqlite3
.支持库 spec
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 SQL_lc, Sqlite数据库

.子程序 _按钮2_被单击
.局部变量 SQL_表, Sqlite表

' 该例程源码来自亦行(yx)博客,由yx编写发布。如有转载请注明来源www.yxblog.cn
.如果真 (SQL_lc.打开 (取运行目录 () + “\lc.db”, 假) = 假)
    信息框 (“数据库打开失败”, 0, , )
    返回 ()
.如果真结束
调试输出 (取运行目录 ())
.如果真 (SQL_表.打开 (“ceshi”, SQL_lc) = 假)
    信息框 (“表打开失败”, 0, , )
    返回 ()
.如果真结束

SQL_表.插入 ()
SQL_表.写字段值 (“name”, 编辑框_data1.内容)
SQL_表.写字段值 (“zs”, 到整数 (编辑框_data3.内容))
SQL_表.提交 ()
SQL_表.关闭 ()
SQL_lc.关闭 ()

.子程序 __启动窗口_创建完毕



.子程序 _按钮1_被单击
.局部变量 SQL_表, Sqlite表
.局部变量 SQL_个数记录, 整数型
.局部变量 索引, 整数型

.如果真 (SQL_lc.打开 (取运行目录 () + “\lc.db”, 假) = 假)
    信息框 (“数据库打开失败”, 0, , )
    返回 ()
.如果真结束
调试输出 (取运行目录 ())
.如果真 (SQL_表.打开 (“ceshi”, SQL_lc) = 假)
    信息框 (“表打开失败”, 0, , )
    返回 ()
.如果真结束

SQL_个数记录 = SQL_表.取记录个数 ()
调试输出 (SQL_个数记录)
SQL_表.到首记录 ()
.计次循环首 (SQL_个数记录, )
    索引 = 超级列表框1.插入表项 (-1, SQL_表.读字段文本值 (“uid”, ), , , , )
    超级列表框1.置标题 (索引, 1, SQL_表.读字段文本值 (“name”, ))
    超级列表框1.置标题 (索引, 2, SQL_表.读字段文本值 (“zs”, ))
    SQL_表.到下一记录 ()
.计次循环尾 ()
SQL_表.关闭 ()
SQL_lc.关闭 ()

下载信息 源码名称: SQL数据库 源码适用: 易语言
下载地址
亦行
  • 版权声明: 发表于 2018-08-2821:12:23,共 839 字。
  • 转载注明:https://www.nanzl.com/archives/614

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: