易语言SQL数据库调用例程

yx 2018-08-2821:12:23易语言SQL数据库调用例程已关闭评论112.8K阅读2分47秒

易语言SQL数据库调用例程(记录与读取)

易语言SQL数据库调用例程

.版本 2
.支持库 sqlite3
.支持库 spec
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 SQL_lc, Sqlite数据库

.子程序 _按钮2_被单击
.局部变量 SQL_表, Sqlite表

' 该例程源码来自亦行(yx)博客,由yx编写发布。如有转载请注明来源www.yxblog.cn
.如果真 (SQL_lc.打开 (取运行目录 () + “\lc.db”, 假) = 假)
    信息框 (“数据库打开失败”, 0, , )
    返回 ()
.如果真结束
调试输出 (取运行目录 ())
.如果真 (SQL_表.打开 (“ceshi”, SQL_lc) = 假)
    信息框 (“表打开失败”, 0, , )
    返回 ()
.如果真结束

SQL_表.插入 ()
SQL_表.写字段值 (“name”, 编辑框_data1.内容)
SQL_表.写字段值 (“zs”, 到整数 (编辑框_data3.内容))
SQL_表.提交 ()
SQL_表.关闭 ()
SQL_lc.关闭 ()

.子程序 __启动窗口_创建完毕



.子程序 _按钮1_被单击
.局部变量 SQL_表, Sqlite表
.局部变量 SQL_个数记录, 整数型
.局部变量 索引, 整数型

.如果真 (SQL_lc.打开 (取运行目录 () + “\lc.db”, 假) = 假)
    信息框 (“数据库打开失败”, 0, , )
    返回 ()
.如果真结束
调试输出 (取运行目录 ())
.如果真 (SQL_表.打开 (“ceshi”, SQL_lc) = 假)
    信息框 (“表打开失败”, 0, , )
    返回 ()
.如果真结束

SQL_个数记录 = SQL_表.取记录个数 ()
调试输出 (SQL_个数记录)
SQL_表.到首记录 ()
.计次循环首 (SQL_个数记录, )
    索引 = 超级列表框1.插入表项 (-1, SQL_表.读字段文本值 (“uid”, ), , , , )
    超级列表框1.置标题 (索引, 1, SQL_表.读字段文本值 (“name”, ))
    超级列表框1.置标题 (索引, 2, SQL_表.读字段文本值 (“zs”, ))
    SQL_表.到下一记录 ()
.计次循环尾 ()
SQL_表.关闭 ()
SQL_lc.关闭 ()

下载信息 源码名称: SQL数据库 源码适用: 易语言
下载地址
继续阅读
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...