SQLite 超级列表框查找删除

yx 技术探讨SQLite 超级列表框查找删除已关闭评论67,206字数 658阅读2分11秒阅读模式

有很多小伙伴还是不会用SQL查找和删除,会写不会删是不完整的

SQLite 超级列表框查找删除文章源自楠竹林-https://www.nanzl.com/archives/637

'该例程由yx编写发布,如有转载请注明来源
‘超级列表框右键按下事件’
弹出菜单
选中菜单
超级列表框取标题
得到uID  说明:为什么取UID  是因为SQL不能很好的支持中文,所以取数字或纯因为会比较不错

.版本 2
.支持库 iext
.支持库 spec
.支持库 sqlite3

.子程序 _删除_被选择
.局部变量 取出标题, 文本型

取出标题 = 超级列表框_显示.取标题 (超级列表框_显示.现行选中项, 0)
调试输出 (取出标题)
SQL_yx_表.到首记录 ()
调试输出 (SQL_yx_表.查找 (“字段=” + 取出标题))
.如果真 (SQL_yx_表.查找 (“字段=” + 取出标题) = 真)
    SQL_yx_表.删除 ()
    SQL_yx_表.刷新 ()  ‘ 刷新数据库  以便调整当前数据库容量’
    返回 ()

修改数据

.版本 2
.支持库 iext
.支持库 sqlite3

.子程序 修改yx数据
.局部变量 取出标题, 文本型

取出标题 = 超级列表框_显示.取标题 (超级列表框_显示.现行选中项, 0)
SQL_yx_表.到首记录 ()  ‘需要先把数据库跳转到首记录以便查找’
.如果真 (SQL_yx_表.查找 (“字段=” + 取出标题) = 真)  ' SQL查找用法,字段名称=字段值,且中文不能很好的支持。
    SQL_yx_表.编辑 ()
    SQL_yx_表.写字段值 (“字段”, 编辑框_账号所属.内容)
    SQL_yx_表.写字段值 (“字段”, 编辑框_账号.内容)
    .判断开始 (SQL_yx_表.提交 () = 真)
    .默认
    .判断结束
    返回 ()
.如果真结束

学会了吗?看不明白可以在下方留言哟!文章源自楠竹林-https://www.nanzl.com/archives/637 文章源自楠竹林-https://www.nanzl.com/archives/637

yx