SQLite 超级列表框查找删除

yx 2018-09-0115:51:06SQLite 超级列表框查找删除已关闭评论68.6K阅读2分11秒

有很多小伙伴还是不会用SQL查找和删除,会写不会删是不完整的

SQLite 超级列表框查找删除

'该例程由yx编写发布,如有转载请注明来源
‘超级列表框右键按下事件’
弹出菜单
选中菜单
超级列表框取标题
得到uID  说明:为什么取UID  是因为SQL不能很好的支持中文,所以取数字或纯因为会比较不错

.版本 2
.支持库 iext
.支持库 spec
.支持库 sqlite3

.子程序 _删除_被选择
.局部变量 取出标题, 文本型

取出标题 = 超级列表框_显示.取标题 (超级列表框_显示.现行选中项, 0)
调试输出 (取出标题)
SQL_yx_表.到首记录 ()
调试输出 (SQL_yx_表.查找 (“字段=” + 取出标题))
.如果真 (SQL_yx_表.查找 (“字段=” + 取出标题) = 真)
    SQL_yx_表.删除 ()
    SQL_yx_表.刷新 ()  ‘ 刷新数据库  以便调整当前数据库容量’
    返回 ()

修改数据

.版本 2
.支持库 iext
.支持库 sqlite3

.子程序 修改yx数据
.局部变量 取出标题, 文本型

取出标题 = 超级列表框_显示.取标题 (超级列表框_显示.现行选中项, 0)
SQL_yx_表.到首记录 ()  ‘需要先把数据库跳转到首记录以便查找’
.如果真 (SQL_yx_表.查找 (“字段=” + 取出标题) = 真)  ' SQL查找用法,字段名称=字段值,且中文不能很好的支持。
    SQL_yx_表.编辑 ()
    SQL_yx_表.写字段值 (“字段”, 编辑框_账号所属.内容)
    SQL_yx_表.写字段值 (“字段”, 编辑框_账号.内容)
    .判断开始 (SQL_yx_表.提交 () = 真)
    .默认
    .判断结束
    返回 ()
.如果真结束

学会了吗?看不明白可以在下方留言哟!

世界唯一不变的就是变化,世界唯一可能的就是不可能。
易语言DLL公开程序中无法自定义数据类型解决办法 技术分享

易语言DLL公开程序中无法自定义数据类型解决办法

在编写动态链接库时发现无法公开自定义数据库,只能提供基本数据库且不包含字节集。   其报错为 错误(10063): 被取地址的子程序“Entrance”的参数 2 必须是基本数据类型,且不能...
WindowsAPI易语言内介绍和使用 技术分享

WindowsAPI易语言内介绍和使用

引用百度百科介绍:Windows 这个多作业系统除了协调应用程序的执行、分配内存、管理资源之外, 它同时也是一个很大的服务中心,调用这个服务中心的各种服务(每一种服务就是一个函数),可以帮应用程式达到...
了解和掌握易语言面向对象 技术分享

了解和掌握易语言面向对象

许久许久,忙于工作和结婚无法更新一些实用的技术文章,趁女神节有点业余时间写下这篇“面向对象”技术分享文章 前言  希望你在看完这篇文章后能够了解 面向对象的含义,了解什么是面向对象 知道什么是类,了解...
百度统计/SSP等新建或验证网站失败解决办法 技术分享

百度统计/SSP等新建或验证网站失败解决办法

在这里我必须吐槽一下百度了,竟然不支持HTTPS验证 看到引用了吗? 获取验证文件失败或文件错误,请您确认正确放置后,再次点击“完成验证”按钮” 你没有看错,因为百度不支持HTTPS验证,你需要关掉H...