易语言局域网文件传输带聊天功能例程

yx 技术探讨易语言局域网文件传输带聊天功能例程已关闭评论178,814字数 589阅读1分57秒阅读模式

这是我大约在半年以前的作品,但是当时由于一些原因并没有完成。算是个半成品,有兴趣的可以下载来研究一下

易语言局域网文件传输带聊天功能例程
易语言局域网文件传输带聊天功能例程文章源自楠竹林-https://www.nanzl.com/archives/641

.版本 2
.支持库 eAPI

' 源码例程来自亦行(yx)博客,由yx编写发布。如有转载请注明来源www.yxblog.cn
局域_IP = 取IP地址 ()
标题 = “[” + 局域_IP + “]”

.版本 2
.支持库 iext

.程序集 Customer_模块
.程序集变量 局部_通用变量, 局域_数据成员

.子程序 _按钮1_被单击

.判断开始 (客户1.连接 (连接输入框.内容, 19730) = 真)
    服务器显示.标题 = “服务器连接正常”
.默认
    服务器显示.标题 = “服务器连接异常”
.判断结束


.子程序 _按钮2_被单击


.判断开始 (客户1.发送数据 (“yntx” + 域内通讯发送框.内容) = 真)
    域内通讯框.加入文本 (“ip[我]” + #换行符 + “通讯内容:” + 域内通讯发送框.内容 + #换行符)
.默认
    域内通讯框.加入文本 (“我” + #换行符 + “通讯内容:发送失败” + #换行符)
.判断结束


.子程序 _客户1_数据到达

局部_通用变量.到达 = 客户1.取回数据 ()
.判断开始 (取文本左边 (到文本 (局部_通用变量.到达), 4) = “yntx”)
    域内通讯框.加入文本 (“ip[” + 连接输入框.内容 + “]” + #换行符 + “通讯内容:” + 取文本右边 (到文本 (局部_通用变量.到达), 取文本长度 (到文本 (局部_通用变量.到达)) - 4) + #换行符)
.默认

.判断结束

下载信息 源码名称: 域内通信
最近更新2023-1-12
下载地址 查看演示
文章源自楠竹林-https://www.nanzl.com/archives/641文章源自楠竹林-https://www.nanzl.com/archives/641
yx