易语言局域网文件传输带聊天功能例程

yx 2018-09-0215:06:08易语言局域网文件传输带聊天功能例程已关闭评论182.8K阅读1分57秒

这是我大约在半年以前的作品,但是当时由于一些原因并没有完成。算是个半成品,有兴趣的可以下载来研究一下

易语言局域网文件传输带聊天功能例程
易语言局域网文件传输带聊天功能例程

.版本 2
.支持库 eAPI

' 源码例程来自亦行(yx)博客,由yx编写发布。如有转载请注明来源www.yxblog.cn
局域_IP = 取IP地址 ()
标题 = “[” + 局域_IP + “]”

.版本 2
.支持库 iext

.程序集 Customer_模块
.程序集变量 局部_通用变量, 局域_数据成员

.子程序 _按钮1_被单击

.判断开始 (客户1.连接 (连接输入框.内容, 19730) = 真)
    服务器显示.标题 = “服务器连接正常”
.默认
    服务器显示.标题 = “服务器连接异常”
.判断结束


.子程序 _按钮2_被单击


.判断开始 (客户1.发送数据 (“yntx” + 域内通讯发送框.内容) = 真)
    域内通讯框.加入文本 (“ip[我]” + #换行符 + “通讯内容:” + 域内通讯发送框.内容 + #换行符)
.默认
    域内通讯框.加入文本 (“我” + #换行符 + “通讯内容:发送失败” + #换行符)
.判断结束


.子程序 _客户1_数据到达

局部_通用变量.到达 = 客户1.取回数据 ()
.判断开始 (取文本左边 (到文本 (局部_通用变量.到达), 4) = “yntx”)
    域内通讯框.加入文本 (“ip[” + 连接输入框.内容 + “]” + #换行符 + “通讯内容:” + 取文本右边 (到文本 (局部_通用变量.到达), 取文本长度 (到文本 (局部_通用变量.到达)) - 4) + #换行符)
.默认

.判断结束

下载信息 源码名称: 域内通信 源码适用: 易语言 WIN
下载地址 查看演示
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...