基于MYPCQQ写的商业统计系统源码

yx 技术探讨基于MYPCQQ写的商业统计系统源码已关闭评论84,129字数 1027阅读3分25秒阅读模式

这是我16年写的一款基于MYPCQQ写的商业统计系统,铭牌统计当时是整个机器人插件领域首款统计系统。喜欢机器人的也是很有学习价值的。后来关闭悠优游社区后便和喵喵群管一起停止更新了,现在把源码贴出来供各位学习(包内共有三个源码,)

基于MYPCQQ写的商业统计系统源码文章源自楠竹林-https://www.nanzl.com/archives/651

部分源码

.版本 2

.程序集 Statistical, , , 简称SDPC,统计处理中心

.子程序 创建ID, 文本型, , 创建所有角色进行工作
.参数 创建QQ, 文本型
.参数 消息来源, 文本型
.局部变量 是否创建, 文本型
.局部变量 拉取目前所拥有的验证码, 整数型

是否创建 = 读配置项 (取运行目录 () + “\mingpai\data\创建ID.ini”, 创建QQ + 消息来源, “角色”, “NO”)
拉取目前所拥有的验证码 = 到整数 (读配置项 (取运行目录 () + “\mingpai\控制台配置.ini”, “ID”, “ID”, “0”))
.如果真 (是否创建 = “OK”)
    返回 (“[@” + 创建QQ + “] ” + “您好,请勿重复创建,能可以发送查询信息进行查询”)
.如果真结束
.如果真 (是否创建 = “NO”)
    写配置项 (取运行目录 () + “\mingpai\data\创建ID.ini”, 创建QQ + 消息来源, “角色”, “OK”)  ' 此项来记录用户是否创建ID
    写到文件 (取运行目录 () + “\mingpai\testing\” + 创建QQ + 消息来源 + “.txt”, 到字节集 (“123456,”))  ' 此项用来记录用户所邀请的QQ
    写配置项 (取运行目录 () + “\mingpai\data\用户验证中心.ini”, 创建QQ + 消息来源, “群中ID”, 创建QQ)
    写配置项 (取运行目录 () + “\mingpai\data\用户验证中心.ini”, 创建QQ + 消息来源, “验证码”, “未创建”)
    写配置项 (取运行目录 () + “\mingpai\控制台配置.ini”, “ID”, “ID”, 到文本 (拉取目前所拥有的验证码 + 1))
    写配置项 (取运行目录 () + “\mingpai\data\用户验证中心.ini”, 创建QQ + 消息来源, “有效数”, “0”)
    写配置项 (取运行目录 () + “\mingpai\data\用户验证中心.ini”, 创建QQ + 消息来源, “失效数”, “0”)
    写配置项 (取运行目录 () + “\mingpai\data\用户验证中心.ini”, 创建QQ + 消息来源, “综合数”, “0”)
    关闭 ()
    返回 (“[@” + 创建QQ + “] ” + “您的ID已经创建成功,发送查询信息进行查询吧!”)
.如果真结束
返回 (“未知错误,联系管理”)

下载信息 源码名称: 铭牌统计系统 源码大小: 6M(压缩)
最近更新2023-1-12
下载地址 查看演示
文章源自楠竹林-https://www.nanzl.com/archives/651文章源自楠竹林-https://www.nanzl.com/archives/651
继续阅读
yx