基于MYPCQQ写的商业统计系统源码

yx 2018-09-0420:37:36来源:原创基于MYPCQQ写的商业统计系统源码已关闭评论85.6K阅读3分25秒

这是我16年写的一款基于MYPCQQ写的商业统计系统,铭牌统计当时是整个机器人插件领域首款统计系统。喜欢机器人的也是很有学习价值的。后来关闭悠优游社区后便和喵喵群管一起停止更新了,现在把源码贴出来供各位学习(包内共有三个源码,)

基于MYPCQQ写的商业统计系统源码

部分源码

.版本 2

.程序集 Statistical, , , 简称SDPC,统计处理中心

.子程序 创建ID, 文本型, , 创建所有角色进行工作
.参数 创建QQ, 文本型
.参数 消息来源, 文本型
.局部变量 是否创建, 文本型
.局部变量 拉取目前所拥有的验证码, 整数型

是否创建 = 读配置项 (取运行目录 () + “\mingpai\data\创建ID.ini”, 创建QQ + 消息来源, “角色”, “NO”)
拉取目前所拥有的验证码 = 到整数 (读配置项 (取运行目录 () + “\mingpai\控制台配置.ini”, “ID”, “ID”, “0”))
.如果真 (是否创建 = “OK”)
    返回 (“[@” + 创建QQ + “] ” + “您好,请勿重复创建,能可以发送查询信息进行查询”)
.如果真结束
.如果真 (是否创建 = “NO”)
    写配置项 (取运行目录 () + “\mingpai\data\创建ID.ini”, 创建QQ + 消息来源, “角色”, “OK”)  ' 此项来记录用户是否创建ID
    写到文件 (取运行目录 () + “\mingpai\testing\” + 创建QQ + 消息来源 + “.txt”, 到字节集 (“123456,”))  ' 此项用来记录用户所邀请的QQ
    写配置项 (取运行目录 () + “\mingpai\data\用户验证中心.ini”, 创建QQ + 消息来源, “群中ID”, 创建QQ)
    写配置项 (取运行目录 () + “\mingpai\data\用户验证中心.ini”, 创建QQ + 消息来源, “验证码”, “未创建”)
    写配置项 (取运行目录 () + “\mingpai\控制台配置.ini”, “ID”, “ID”, 到文本 (拉取目前所拥有的验证码 + 1))
    写配置项 (取运行目录 () + “\mingpai\data\用户验证中心.ini”, 创建QQ + 消息来源, “有效数”, “0”)
    写配置项 (取运行目录 () + “\mingpai\data\用户验证中心.ini”, 创建QQ + 消息来源, “失效数”, “0”)
    写配置项 (取运行目录 () + “\mingpai\data\用户验证中心.ini”, 创建QQ + 消息来源, “综合数”, “0”)
    关闭 ()
    返回 (“[@” + 创建QQ + “] ” + “您的ID已经创建成功,发送查询信息进行查询吧!”)
.如果真结束
返回 (“未知错误,联系管理”)

下载信息 源码名称: 铭牌统计系统 源码适用: 易语言 MYPCQQ平台 酷Q 源码版本: 3.0 源码大小: 6M(压缩)
下载地址 查看演示
继续阅读
世界唯一不变的就是变化,世界唯一可能的就是不可能。
  • 版权声明 本文源自 原创, 整理 发表于 2018-09-0420:37:36
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...