基于MYPCQQ写的群管插件源码

yx 技术探讨基于MYPCQQ写的群管插件源码已关闭评论91,874字数 896阅读2分59秒阅读模式

这是一个简单的QQ机器人群管插件源码,这个源码比较简单,但对于入门是可以学习的。后面我将继续公布喵喵源码

基于MYPCQQ写的群管插件源码文章源自楠竹林-https://www.nanzl.com/archives/663

.版本 2

.子程序 时间
.局部变量 返回时间, 文本型
.局部变量 报时_开启, 文本型
.局部变量 接收, 文本型
.局部变量 文本, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 发送, 文本型

返回时间 = 到文本 (取现行时间 ())
报时_开启 = 读配置项 (取运行目录 () + “\maojun.ini”, “猫君监控”, “报时_监控”, )
接收 = 到文本 (读入文件 (取运行目录 () + “\maojun.txt”))
发送 = 读配置项 (取运行目录 () + “\maojun.ini”, “猫君监控”, “机器人Q”, )
.如果真 (报时_开启 = “开启”)
    文本 = 分割文本 (接收, “,”, )
    .计次循环首 (取数组成员数 (文本), i)
        .如果真 (取分钟 (取现行时间 ()) = 0 且 取秒 (取现行时间 ()) = 1)
            Api_SendMsg (发送, 2, 0, 文本 [i], “840995510”, “整点报时:” + 到文本 (取现行时间 ()))
        .如果真结束

    .计次循环尾 ()


.如果真结束

用于更新时间 ()

.子程序 用于更新时间

延时 (1000)
时间 ()



.子程序 授权验证, 逻辑型
.参数 M, 文本型
.参数 N, 文本型
.局部变量 获取, 文本型
.局部变量 返回数据, 文本型
.局部变量 授权数据, 文本型
.局部变量 c, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 b, 文本型, , "0"
.局部变量 a, 整数型
.局部变量 o, 文本型

' 获取 = 到文本 (HTTP读文件 (地址))
' 授权数据 = 到文本 (HTTP读文件 (地址))
返回数据 = M
返回数据 = 子文本替换 (返回数据, “-”, “”, 1, 3, 真)
c = 分割文本 (授权数据, #换行符, )
.计次循环首 (取数组下标 (c, ), i)
    .如果真 (c [i] ≠ “” 且 寻找文本 (N, c [i], , 真) ≠ -1)
        o = c [i]
        c = 分割文本 (获取, #换行符, )
        .计次循环首 (取数组下标 (c, ), i)
            .如果真 (c [i] ≠ “” 且 寻找文本 (N + 返回数据, c [i], , 真) ≠ -1)
                .判断开始 (是否存在黑名单 (o) = 真)
                    返回 (假)
                .默认
                    返回 (真)
                .判断结束

            .如果真结束

        .计次循环尾 ()

    .如果真结束

.计次循环尾 ()
返回 (假)

下载信息 源码名称: 猫君监控
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/663文章源自楠竹林-https://www.nanzl.com/archives/663
继续阅读
yx