基于MYPCQQ写的群管插件源码

yx 2018-09-0618:46:02基于MYPCQQ写的群管插件源码已关闭评论93.3K阅读2分59秒

这是一个简单的QQ机器人群管插件源码,这个源码比较简单,但对于入门是可以学习的。后面我将继续公布喵喵源码

基于MYPCQQ写的群管插件源码

.版本 2

.子程序 时间
.局部变量 返回时间, 文本型
.局部变量 报时_开启, 文本型
.局部变量 接收, 文本型
.局部变量 文本, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 发送, 文本型

返回时间 = 到文本 (取现行时间 ())
报时_开启 = 读配置项 (取运行目录 () + “\maojun.ini”, “猫君监控”, “报时_监控”, )
接收 = 到文本 (读入文件 (取运行目录 () + “\maojun.txt”))
发送 = 读配置项 (取运行目录 () + “\maojun.ini”, “猫君监控”, “机器人Q”, )
.如果真 (报时_开启 = “开启”)
    文本 = 分割文本 (接收, “,”, )
    .计次循环首 (取数组成员数 (文本), i)
        .如果真 (取分钟 (取现行时间 ()) = 0 且 取秒 (取现行时间 ()) = 1)
            Api_SendMsg (发送, 2, 0, 文本 [i], “840995510”, “整点报时:” + 到文本 (取现行时间 ()))
        .如果真结束

    .计次循环尾 ()


.如果真结束

用于更新时间 ()

.子程序 用于更新时间

延时 (1000)
时间 ()



.子程序 授权验证, 逻辑型
.参数 M, 文本型
.参数 N, 文本型
.局部变量 获取, 文本型
.局部变量 返回数据, 文本型
.局部变量 授权数据, 文本型
.局部变量 c, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 b, 文本型, , "0"
.局部变量 a, 整数型
.局部变量 o, 文本型

' 获取 = 到文本 (HTTP读文件 (地址))
' 授权数据 = 到文本 (HTTP读文件 (地址))
返回数据 = M
返回数据 = 子文本替换 (返回数据, “-”, “”, 1, 3, 真)
c = 分割文本 (授权数据, #换行符, )
.计次循环首 (取数组下标 (c, ), i)
    .如果真 (c [i] ≠ “” 且 寻找文本 (N, c [i], , 真) ≠ -1)
        o = c [i]
        c = 分割文本 (获取, #换行符, )
        .计次循环首 (取数组下标 (c, ), i)
            .如果真 (c [i] ≠ “” 且 寻找文本 (N + 返回数据, c [i], , 真) ≠ -1)
                .判断开始 (是否存在黑名单 (o) = 真)
                    返回 (假)
                .默认
                    返回 (真)
                .判断结束

            .如果真结束

        .计次循环尾 ()

    .如果真结束

.计次循环尾 ()
返回 (假)

下载信息 源码名称: 猫君监控 源码适用: 易语言 MYPCQQ平台
下载地址
继续阅读
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...