图灵/茉莉机器人聊天交互自动互补源码例程

yx 技术探讨1 93,5131字数 559阅读1分51秒阅读模式

这是一例交互例程,利用图灵和茉莉做一个聊天机器人,输入KEY还能学习。对于做机器人插件的还是很有帮助的

图灵/茉莉机器人聊天交互自动互补源码例程文章源自楠竹林-https://www.nanzl.com/archives/667

.版本 2
.支持库 spec

.子程序 图灵_2, 文本型, 公开
.参数 msg, 文本型
.参数 KEY, 文本型
.局部变量 发送内容, 文本型
.局部变量 接口, 文本型
.局部变量 昵称返回, 文本型
.局部变量 内容, 文本型
.局部变量 代码, 文本型

内容 = 子文本替换 (msg, “ ”, “”, , , 真)
内容 = 子文本替换 (内容, #换行符, “”, , , 真)
接口 = 读配置项 (取运行目录 () + “xt.ini”, “pz”, “jk”, KEY)
.如果真 (删全部空 (接口) = “”)
    接口 = KEY
.如果真结束
发送内容 = 编码_utf8到gb2312 (到文本 (网页_访问 (“http://www.tuling123.com/openapi/api?key=” + 接口 + “&info=” + 编码_URL编码 (内容, 真, 真))))
代码 = 文本_取出中间文本 (发送内容, “code” + #引号 + “:”, “,”)
调试输出 (代码)
.判断开始 (代码 = “40004”)
    发送内容 = “此图灵ID调用次数已经用尽请更换!”
.判断 (代码 = “100000”)
    发送内容 = 文本_取出中间文本 (发送内容, #常量1_q, #常量2_h, , )
    发送内容 = 子文本替换 (发送内容, “
”, “\n”, , , 真)
.默认

.判断结束
返回 (发送内容)

下载信息 源码名称: 图灵/茉莉机器人交互源码
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/667文章源自楠竹林-https://www.nanzl.com/archives/667
yx