图灵/茉莉机器人聊天交互自动互补源码例程

yx 2018-09-0718:38:451 95.1K1阅读1分51秒

这是一例交互例程,利用图灵和茉莉做一个聊天机器人,输入KEY还能学习。对于做机器人插件的还是很有帮助的

图灵/茉莉机器人聊天交互自动互补源码例程

.版本 2
.支持库 spec

.子程序 图灵_2, 文本型, 公开
.参数 msg, 文本型
.参数 KEY, 文本型
.局部变量 发送内容, 文本型
.局部变量 接口, 文本型
.局部变量 昵称返回, 文本型
.局部变量 内容, 文本型
.局部变量 代码, 文本型

内容 = 子文本替换 (msg, “ ”, “”, , , 真)
内容 = 子文本替换 (内容, #换行符, “”, , , 真)
接口 = 读配置项 (取运行目录 () + “xt.ini”, “pz”, “jk”, KEY)
.如果真 (删全部空 (接口) = “”)
    接口 = KEY
.如果真结束
发送内容 = 编码_utf8到gb2312 (到文本 (网页_访问 (“http://www.tuling123.com/openapi/api?key=” + 接口 + “&info=” + 编码_URL编码 (内容, 真, 真))))
代码 = 文本_取出中间文本 (发送内容, “code” + #引号 + “:”, “,”)
调试输出 (代码)
.判断开始 (代码 = “40004”)
    发送内容 = “此图灵ID调用次数已经用尽请更换!”
.判断 (代码 = “100000”)
    发送内容 = 文本_取出中间文本 (发送内容, #常量1_q, #常量2_h, , )
    发送内容 = 子文本替换 (发送内容, “
”, “\n”, , , 真)
.默认

.判断结束
返回 (发送内容)

下载信息 源码名称: 图灵/茉莉机器人交互源码 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...