电脑系统时间矫正源码例程

yx 2018-09-0820:21:43电脑系统时间矫正源码例程已关闭评论64.8K阅读4分17秒

这个源码来源我也不太清楚了,很久以前就存在我的电脑上。

电脑系统时间矫正源码例程

.版本 2
.支持库 EThread
.支持库 spec

.程序集 窗口程序集1
.程序集变量 网络, 日期时间型
.程序集变量 本地网络差, 双精度小数型

.子程序 __启动窗口_创建完毕

' 该源码来自亦行博客,www.yxblog.cn
.如果真 (是否在临时目录 ())
    信息框 (“请不要在压缩包内直接运行或放在目录中包含\Temp\的文件夹中。”, 64, “提示”)
    结束 ()
.如果真结束
置外形图片 (底图, #品红)
可视 = 真
标题栏.宽度 = 835
标签透明 (标题栏)
标签透明 (标签)
设置标题 (“时间校对器”)
标题 = “时间校对器”
开机.选中 = 文件是否存在 (取目录 (“Startup”) + “\自动校时.lnk”)
桌面.选中 = 文件是否存在 (取目录 (“Desktop”) + “\自动校时.lnk”)
启动线程 (&校对线程, , )

.子程序 标签透明
.参数 要透明的标签, 标签

要透明的标签.底图方式 = 0
要透明的标签.可视 = 假
处理事件 ()
要透明的标签.底图 = 快照 (要透明的标签.取窗口句柄 (), , )
要透明的标签.可视 = 真

.子程序 设置标题
.参数 设置标题, 文本型

标题栏.标题 = “     ” + 设置标题

.子程序 _标题栏_鼠标左键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

发送信息 (161, 2, 0)

.子程序 _最小化按钮_被单击

_启动窗口.发送信息 (274, 61473, 0)

.子程序 _关闭按钮_被单击

显示时间.时钟周期 = 0
校对.时钟周期 = 0
处理事件 ()
结束 ()

.子程序 _校对_周期事件

启动线程 (&校对线程, , )

.子程序 校对线程

.判断开始 (客户1.连接 (“time-a.timefreq.bldrdoc.gov”, 13) = 真)

.判断 (客户1.连接 (“time-b.timefreq.bldrdoc.gov”, 13) = 真)

.判断 (客户1.连接 (“time-c.timefreq.bldrdoc.gov”, 13) = 真)

.判断 (客户1.连接 (“time-a.nist.gov”, 13) = 真)

.判断 (客户1.连接 (“time-b.nist.gov”, 13) = 真)

.默认

.判断结束


.子程序 _客户1_数据到达
.局部变量 取回数据, 文本型
.局部变量 时间, 文本型, , "0"
.局部变量 日期, 文本型, , "3"
.局部变量 命令行, 文本型, , "0"

取回数据 = 取字节集数据 (客户1.取回数据 (), #文本型, )
调试输出 (取回数据)
时间 = 分割文本 (取回数据, “ ”, )
日期 = 分割文本 (时间 [2], “-”, )
日期 [1] = “20” + 日期 [1]
网络 = 增减时间 (到时间 (日期 [1] + “/” + 日期 [2] + “/” + 日期 [3] + “ ” + 时间 [3]), #小时, 8)
本地网络差 = 取时间间隔 (网络, 取现行时间 (), 8)
网络时间.标题 = “当前网络时间: ” + 时间格式化 (网络)
同步.禁止 = 假
取命令行 (命令行)
.如果真 (取数组成员数 (命令行) > 0)
    .如果真 (命令行 [1] = “auto”)
        置现行时间 (增减时间 (取现行时间 (), 8, 本地网络差))
        标签.标题 = “自动校时完成”
        标签.文本颜色 = #红色
        处理事件 ()
        延迟 (1000)
        结束 ()

下载信息 源码名称: 时间矫正 源码适用: 易语言
下载地址
继续阅读
世界唯一不变的就是变化,世界唯一可能的就是不可能。
易语言DLL公开程序中无法自定义数据类型解决办法 技术分享

易语言DLL公开程序中无法自定义数据类型解决办法

在编写动态链接库时发现无法公开自定义数据库,只能提供基本数据库且不包含字节集。   其报错为 错误(10063): 被取地址的子程序“Entrance”的参数 2 必须是基本数据类型,且不能...
了解和掌握易语言面向对象 技术分享

了解和掌握易语言面向对象

许久许久,忙于工作和结婚无法更新一些实用的技术文章,趁女神节有点业余时间写下这篇“面向对象”技术分享文章 前言  希望你在看完这篇文章后能够了解 面向对象的含义,了解什么是面向对象 知道什么是类,了解...
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...