易语言取系统所有盘符例程源码

yx 2018-09-1021:24:12易语言取系统所有盘符例程源码已关闭评论95.7K1阅读0分42秒

用简单的方式取系统盘符

易语言取系统所有盘符例程源码

.版本 2

.程序集 窗口程序集1

.子程序 __启动窗口_创建完毕
.局部变量 盘符, 字节集
.局部变量 盘符名称, 字节集, , "0"
.局部变量 i, 整数型
.局部变量 长度, 整数型

盘符 = 取空白字节集 (255)
长度 = 获取逻辑驱动器字串 (255, 盘符)
盘符 = 取字节集左边 (盘符, 长度)
盘符名称 = 分割字节集 (盘符, { 0 }, )
.计次循环首 (取数组成员数 (盘符名称), i)
    列表框1.加入项目 (到文本 (盘符名称 [i]), )
.计次循环尾 ()

下载信息 源码名称: 系统盘符 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...