易语言“易包”做软件插件系统源码例程

yx 技术探讨易语言“易包”做软件插件系统源码例程已关闭评论112,365字数 252阅读0分50秒阅读模式

亦行最近在做机器人的时候发现用dll作为插件脚本比起易包效率上要差许多。但缺陷就是没法支持其他语言进行插件开发。

易语言“易包”做软件插件系统源码例程文章源自楠竹林-https://www.nanzl.com/archives/680

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 文件数组, 文本型, , "0"

.子程序 __启动窗口_创建完毕

插件初始化载入 ()

.子程序 插件初始化载入
.局部变量 i, 整数型

API函数_枚举文件 (取运行目录 () + “\epk”, “*.epk”, 文件数组, 真)
.计次循环首 (取数组成员数 (文件数组), i)
    载入易包数据 (“epk”, 读入文件 (文件数组 [i]))
    信息显示 (超级列表框1)
.计次循环尾 ()

部分源码
下载信息 源码名称: 易包插件系统
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/680文章源自楠竹林-https://www.nanzl.com/archives/680
yx