易语言“易包”做软件插件系统源码例程

yx 2018-09-1117:45:10易语言“易包”做软件插件系统源码例程已关闭评论113.9K阅读0分50秒

亦行最近在做机器人的时候发现用dll作为插件脚本比起易包效率上要差许多。但缺陷就是没法支持其他语言进行插件开发。

易语言“易包”做软件插件系统源码例程

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 文件数组, 文本型, , "0"

.子程序 __启动窗口_创建完毕

插件初始化载入 ()

.子程序 插件初始化载入
.局部变量 i, 整数型

API函数_枚举文件 (取运行目录 () + “\epk”, “*.epk”, 文件数组, 真)
.计次循环首 (取数组成员数 (文件数组), i)
    载入易包数据 (“epk”, 读入文件 (文件数组 [i]))
    信息显示 (超级列表框1)
.计次循环尾 ()

部分源码
下载信息 源码名称: 易包插件系统 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...