易语言驱动保护进程例程源码

yx 技术探讨易语言驱动保护进程例程源码已关闭评论173,3631字数 631阅读2分6秒阅读模式

驱动保护进程例程,前些年收藏的源码。也是很有学习价值的

易语言驱动保护进程例程源码文章源自楠竹林-https://www.nanzl.com/archives/685

.版本 2

.程序集 窗口程序集1
.程序集变量 驱动, 驱动操作保护类

.子程序 __启动窗口_创建完毕

目标进程ID = 取自进程ID ()

.子程序 _按钮1_被单击

.判断开始 (驱动.初始化保护驱动 (“mydri.sys”))
    信息框 (“驱动装载成功”, 0, )
.默认
    信息框 (“驱动装载失败”, 0, )
.判断结束


.子程序 __启动窗口_将被销毁

.判断开始 (驱动.卸载驱动程序 ())
    信息框 (“驱动卸载成功”, 0, )
.默认
    信息框 (“驱动卸载失败”, 0, )
.判断结束


.子程序 _按钮4_被单击

.判断开始 (驱动.检测驱动是否安装 ())
    信息框 (“驱动正常工作”, 0, )
.默认
    信息框 (“驱动无法连接”, 0, )
.判断结束


.子程序 _按钮3_被单击

.判断开始 (驱动.开始驱动隐藏进程 (目标进程ID))
    信息框 (“目标进程已经被隐藏”, 0, )
.默认
    信息框 (“目标进程隐藏失败”, 0, )
.判断结束


.子程序 _按钮5_被单击

.判断开始 (驱动.停止驱动隐藏进程 ())
    信息框 (“目标进程隐藏被还原”, 0, )
.默认
    信息框 (“目标进程隐藏还原失败”, 0, )
.判断结束


.子程序 _按钮2_被单击

.判断开始 (驱动.开始驱动保护进程 (1660))
    信息框 (“目标进程已经被保护”, 0, )
.默认
    信息框 (“目标进程保护失败”, 0, )
.判断结束


.子程序 _按钮6_被单击

.判断开始 (驱动.停止驱动保护进程 ())
    信息框 (“目标进程保护被还原”, 0, )
.默认
    信息框 (“目标进程保护还原失败”, 0, )

下载信息 源码名称: 驱动保护进程
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/685文章源自楠竹林-https://www.nanzl.com/archives/685
yx