易语言驱动保护进程例程源码

yx 2018-09-1319:47:23易语言驱动保护进程例程源码已关闭评论176.2K1阅读2分6秒

驱动保护进程例程,前些年收藏的源码。也是很有学习价值的

易语言驱动保护进程例程源码

.版本 2

.程序集 窗口程序集1
.程序集变量 驱动, 驱动操作保护类

.子程序 __启动窗口_创建完毕

目标进程ID = 取自进程ID ()

.子程序 _按钮1_被单击

.判断开始 (驱动.初始化保护驱动 (“mydri.sys”))
    信息框 (“驱动装载成功”, 0, )
.默认
    信息框 (“驱动装载失败”, 0, )
.判断结束


.子程序 __启动窗口_将被销毁

.判断开始 (驱动.卸载驱动程序 ())
    信息框 (“驱动卸载成功”, 0, )
.默认
    信息框 (“驱动卸载失败”, 0, )
.判断结束


.子程序 _按钮4_被单击

.判断开始 (驱动.检测驱动是否安装 ())
    信息框 (“驱动正常工作”, 0, )
.默认
    信息框 (“驱动无法连接”, 0, )
.判断结束


.子程序 _按钮3_被单击

.判断开始 (驱动.开始驱动隐藏进程 (目标进程ID))
    信息框 (“目标进程已经被隐藏”, 0, )
.默认
    信息框 (“目标进程隐藏失败”, 0, )
.判断结束


.子程序 _按钮5_被单击

.判断开始 (驱动.停止驱动隐藏进程 ())
    信息框 (“目标进程隐藏被还原”, 0, )
.默认
    信息框 (“目标进程隐藏还原失败”, 0, )
.判断结束


.子程序 _按钮2_被单击

.判断开始 (驱动.开始驱动保护进程 (1660))
    信息框 (“目标进程已经被保护”, 0, )
.默认
    信息框 (“目标进程保护失败”, 0, )
.判断结束


.子程序 _按钮6_被单击

.判断开始 (驱动.停止驱动保护进程 ())
    信息框 (“目标进程保护被还原”, 0, )
.默认
    信息框 (“目标进程保护还原失败”, 0, )

下载信息 源码名称: 驱动保护进程 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...