易语言全盘查找指定文件并返回地址

yx 技术探讨易语言全盘查找指定文件并返回地址已关闭评论77,5031字数 420阅读1分24秒阅读模式

易语言全盘查找指定文件并返回地址,类似于全盘扫描文件,可以学习一下

易语言全盘查找指定文件并返回地址文章源自楠竹林-https://www.nanzl.com/archives/712

.版本 2
.支持库 iext

.子程序 列表, , , ***寻找目录下的所有子目录**
.参数 路径, 文本型
.参数 查找的文件, 文本型, , 如果模糊查找输入关键词即可
.局部变量 子目录, 文本型
.局部变量 文件名, 文本型

子目录 = 寻找文件 (路径 + “*.*”, #子目录)
.判断循环首 (子目录 ≠ “” 且 找到 = 假)
    .如果真 (取文本左边 (子目录, 1) ≠ “.”)
        .如果真 (文件是否存在 (路径 + 子目录 + “\” + 查找的文件))
            编辑框2.加入文本 (路径 + 子目录 + “\” + 查找的文件)
            找到 = 真  ' 本来用跳出循环(),nnd居然跳不出循环才用这招
            到循环尾 ()
        .如果真结束
        列表 (路径 + 子目录 + “\”, 编辑框1.内容)
        状态条1.置文本 (0, 路径 + 子目录)
    .如果真结束
    子目录 = 寻找文件 (, #子目录)
.判断循环尾 ()
.如果真 (找到)
    状态条1.置文本 (0, “文件已找到!”)
    返回 ()
.如果真结束
状态条1.置文本 (0, “没有找到文件!”)

下载信息 源码名称: 搜索指定文件
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/712文章源自楠竹林-https://www.nanzl.com/archives/712
yx