易语言全盘查找指定文件并返回地址

yx 2018-09-1821:40:06易语言全盘查找指定文件并返回地址已关闭评论79.3K阅读1分24秒

易语言全盘查找指定文件并返回地址,类似于全盘扫描文件,可以学习一下

易语言全盘查找指定文件并返回地址

.版本 2
.支持库 iext

.子程序 列表, , , ***寻找目录下的所有子目录**
.参数 路径, 文本型
.参数 查找的文件, 文本型, , 如果模糊查找输入关键词即可
.局部变量 子目录, 文本型
.局部变量 文件名, 文本型

子目录 = 寻找文件 (路径 + “*.*”, #子目录)
.判断循环首 (子目录 ≠ “” 且 找到 = 假)
    .如果真 (取文本左边 (子目录, 1) ≠ “.”)
        .如果真 (文件是否存在 (路径 + 子目录 + “\” + 查找的文件))
            编辑框2.加入文本 (路径 + 子目录 + “\” + 查找的文件)
            找到 = 真  ' 本来用跳出循环(),nnd居然跳不出循环才用这招
            到循环尾 ()
        .如果真结束
        列表 (路径 + 子目录 + “\”, 编辑框1.内容)
        状态条1.置文本 (0, 路径 + 子目录)
    .如果真结束
    子目录 = 寻找文件 (, #子目录)
.判断循环尾 ()
.如果真 (找到)
    状态条1.置文本 (0, “文件已找到!”)
    返回 ()
.如果真结束
状态条1.置文本 (0, “没有找到文件!”)

下载信息 源码名称: 搜索指定文件 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
易语言DLL公开程序中无法自定义数据类型解决办法 技术分享

易语言DLL公开程序中无法自定义数据类型解决办法

在编写动态链接库时发现无法公开自定义数据库,只能提供基本数据库且不包含字节集。   其报错为 错误(10063): 被取地址的子程序“Entrance”的参数 2 必须是基本数据类型,且不能...
了解和掌握易语言面向对象 技术分享

了解和掌握易语言面向对象

许久许久,忙于工作和结婚无法更新一些实用的技术文章,趁女神节有点业余时间写下这篇“面向对象”技术分享文章 前言  希望你在看完这篇文章后能够了解 面向对象的含义,了解什么是面向对象 知道什么是类,了解...
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...