易语言拖放对象控件演示例程源码(多编辑框接收文件路径)

yx 技术探讨易语言拖放对象控件演示例程源码(多编辑框接收文件路径)已关闭评论103,334字数 352阅读1分10秒阅读模式

很多软件都有拖放文件实现上传或者显示文件等,实际上在易语言中有这么一个控件是可以实现这个功能的

易语言拖放对象控件演示例程源码(多编辑框接收文件路径)文章源自楠竹林-https://www.nanzl.com/archives/720

.版本 2
.支持库 edroptarget

.程序集 窗口程序集1
.程序集变量 程序指针, 整数型

.子程序 __启动窗口_创建完毕

拖放对象1.注册拖放控件 (取窗口句柄 ())
拖放对象1.接收文件 = 真

.子程序 _拖放对象1_得到文件
.参数 接收到的文件路径, 文本型
.局部变量 hwnd, 整数型
.局部变量 xy, POINT
.局部变量 name, 文本型

GetCursorPos (xy)
name = 取空白文本 (10)
hwnd = WindowFromPoint (xy.x, xy.y)
GetClassName (hwnd, name, 10)
.如果真 (到小写 (删尾空 (name)) = “edit”)
    SendMessage (hwnd, 12, 0, 接收到的文件路径)

下载信息 源码名称: 拖放对象
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/720文章源自楠竹林-https://www.nanzl.com/archives/720