易语言拖放对象控件演示例程源码(多编辑框接收文件路径)

yx 2018-09-2019:45:07易语言拖放对象控件演示例程源码(多编辑框接收文件路径)已关闭评论105.6K阅读1分10秒

很多软件都有拖放文件实现上传或者显示文件等,实际上在易语言中有这么一个控件是可以实现这个功能的

易语言拖放对象控件演示例程源码(多编辑框接收文件路径)

.版本 2
.支持库 edroptarget

.程序集 窗口程序集1
.程序集变量 程序指针, 整数型

.子程序 __启动窗口_创建完毕

拖放对象1.注册拖放控件 (取窗口句柄 ())
拖放对象1.接收文件 = 真

.子程序 _拖放对象1_得到文件
.参数 接收到的文件路径, 文本型
.局部变量 hwnd, 整数型
.局部变量 xy, POINT
.局部变量 name, 文本型

GetCursorPos (xy)
name = 取空白文本 (10)
hwnd = WindowFromPoint (xy.x, xy.y)
GetClassName (hwnd, name, 10)
.如果真 (到小写 (删尾空 (name)) = “edit”)
    SendMessage (hwnd, 12, 0, 接收到的文件路径)

下载信息 源码名称: 拖放对象 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...