易语言提取关键字例程源码(这只是个简单的)

yx 2018-09-2122:25:38易语言提取关键字例程源码(这只是个简单的)已关闭评论114.6K2阅读1分28秒

今天在提取相关广告关键字和涉黄关键字的时候写的一个小工具。看看吧

易语言提取关键字例程源码(这只是个简单的)

.版本 2
.支持库 spec

.子程序 _按钮1_被单击
.局部变量 层级内容, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 取出内容, 文本型

层级内容 = 分割文本 (#常量1, #换行符, )
调试输出 (取数组成员数 (层级内容))
调试输出 (层级内容 [99])
.计次循环首 (取数组成员数 (层级内容), i)
    取出内容 = 文本_取文本中间 (层级内容 [i], “value=” + #引号, #引号 + “>”)
    .如果真 (取出内容 ≠ “”)
        .如果真 (寻找文本 (层级内容 [i], “市”, , 假) = -1)
            .如果真 (寻找文本 (层级内容 [i], “省”, , 假) = -1)
                .如果真 (寻找文本 (层级内容 [i], “自治市”, , 假) = -1)
                    .如果真 (寻找文本 (层级内容 [i], “自治县”, , 假) = -1)
                        .如果真 (寻找文本 (层级内容 [i], “自治区”, , 假) = -1)
                            编辑框1.加入文本 (取出内容 + “,”)
                        .如果真结束

                    .如果真结束

                .如果真结束

            .如果真结束

        .如果真结束


    .如果真结束

.计次循环尾 ()


下载信息 源码名称: 提取关键字 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...