易语言提取关键字例程源码(这只是个简单的)

yx 技术探讨易语言提取关键字例程源码(这只是个简单的)已关闭评论112,8342字数 442阅读1分28秒阅读模式

今天在提取相关广告关键字和涉黄关键字的时候写的一个小工具。看看吧

易语言提取关键字例程源码(这只是个简单的)文章源自楠竹林-https://www.nanzl.com/archives/726

.版本 2
.支持库 spec

.子程序 _按钮1_被单击
.局部变量 层级内容, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 取出内容, 文本型

层级内容 = 分割文本 (#常量1, #换行符, )
调试输出 (取数组成员数 (层级内容))
调试输出 (层级内容 [99])
.计次循环首 (取数组成员数 (层级内容), i)
    取出内容 = 文本_取文本中间 (层级内容 [i], “value=” + #引号, #引号 + “>”)
    .如果真 (取出内容 ≠ “”)
        .如果真 (寻找文本 (层级内容 [i], “市”, , 假) = -1)
            .如果真 (寻找文本 (层级内容 [i], “省”, , 假) = -1)
                .如果真 (寻找文本 (层级内容 [i], “自治市”, , 假) = -1)
                    .如果真 (寻找文本 (层级内容 [i], “自治县”, , 假) = -1)
                        .如果真 (寻找文本 (层级内容 [i], “自治区”, , 假) = -1)
                            编辑框1.加入文本 (取出内容 + “,”)
                        .如果真结束

                    .如果真结束

                .如果真结束

            .如果真结束

        .如果真结束


    .如果真结束

.计次循环尾 ()


下载信息 源码名称: 提取关键字
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/726文章源自楠竹林-https://www.nanzl.com/archives/726
yx