易语言TCP连接信息查看器例程源码

yx 2018-09-2722:01:50来源:原创易语言TCP连接信息查看器例程源码已关闭评论91.4K阅读1分8秒

这是多年前收集的一个TCP连接查看器,现目前还能用

易语言TCP连接信息查看器例程源码

.版本 2

.子程序 取状态, 文本型
.参数 参数, 整数型

.判断开始 (参数 = 1)
    返回 (“CLOSE”)
.判断 (参数 = 2)
    返回 (“LISTEN”)
.判断 (参数 = 3)
    返回 (“SYN_SENT”)
.判断 (参数 = 4)
    返回 (“SYN_RCVD”)
.判断 (参数 = 5)
    返回 (“ESTAB”)
.判断 (参数 = 6)
    返回 (“FIN_WAIT1”)
.判断 (参数 = 7)
    返回 (“FIN_WAIT2”)
.判断 (参数 = 8)
    返回 (“CLOSE_WAIT”)
.判断 (参数 = 9)
    返回 (“CLOSING”)
.判断 (参数 = 10)
    返回 (“LAST_ACK”)
.判断 (参数 = 11)
    返回 (“TIME_WAIT”)
.判断 (参数 = 12)
    返回 (“DELETE_TCB”)
.默认
    返回 (“UNKNOWN”)

下载信息 源码名称: TCP 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
  • 版权声明 本文源自 原创, 整理 发表于 2018-09-2722:01:50
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...
易语言“循环体”(变量/计次/判断/循环)初步理解和运用 技术分享

易语言“循环体”(变量/计次/判断/循环)初步理解和运用

引续 因为变量/计次/判断/循环等循环体而经常蒙了,不知其有何用处,具体用法又是什么? 我们先来看看易语言知识库给与的解释 变量循环:执行本命令将利用变量对循环体内的命令进行循环执行。 计次循环:执行...