易语言TCP连接信息查看器例程源码

yx 技术探讨易语言TCP连接信息查看器例程源码已关闭评论89,858字数 344阅读1分8秒阅读模式

这是多年前收集的一个TCP连接查看器,现目前还能用

易语言TCP连接信息查看器例程源码文章源自楠竹林-https://www.nanzl.com/archives/737

.版本 2

.子程序 取状态, 文本型
.参数 参数, 整数型

.判断开始 (参数 = 1)
    返回 (“CLOSE”)
.判断 (参数 = 2)
    返回 (“LISTEN”)
.判断 (参数 = 3)
    返回 (“SYN_SENT”)
.判断 (参数 = 4)
    返回 (“SYN_RCVD”)
.判断 (参数 = 5)
    返回 (“ESTAB”)
.判断 (参数 = 6)
    返回 (“FIN_WAIT1”)
.判断 (参数 = 7)
    返回 (“FIN_WAIT2”)
.判断 (参数 = 8)
    返回 (“CLOSE_WAIT”)
.判断 (参数 = 9)
    返回 (“CLOSING”)
.判断 (参数 = 10)
    返回 (“LAST_ACK”)
.判断 (参数 = 11)
    返回 (“TIME_WAIT”)
.判断 (参数 = 12)
    返回 (“DELETE_TCB”)
.默认
    返回 (“UNKNOWN”)

下载信息 源码名称: TCP
最近更新2023-1-12
下载地址
文章源自楠竹林-https://www.nanzl.com/archives/737文章源自楠竹林-https://www.nanzl.com/archives/737
yx