滴水记写本完整开源(优秀学习源码)

滴水记写本是在滴水记事本基础上扩展而来,其文档加密和独立文本格式协议而具有一定的学习价值。内容编辑丰富,可制作表格等。新手初期接触易语言时此源码非常具有学习价值。但由于其交互繁琐,底层问题不断。也导致其不太好用。现公布其源码

滴水记写本完整开源(优秀学习源码)

‘初始段代码’

.版本 2
.支持库 iext2

.局部变量 命令行, 文本型, , "0"

资源加载 (#皮肤_win10, , , , )
阅读按钮.可视 = 假
全局通用变量.传入保存方式 = 1
全局阅读变量.定义是否传入 = 2
通用对话框1.初始目录 = 取运行目录 ()
全局通用变量.记写本标题 = 读配置项 (取运行目录 () + “\Set\core.ini”, “记写本信息”, “BT”, #名称)
_启动窗口.标题 = 全局通用变量.记写本标题
取命令行 (命令行)
系统_初始化 (取窗口句柄 ())
system.传入记录 = 真
.如果真 (取数组成员数 (命令行) ≠ 0)
    .如果真 (模块_后缀解密转义 (命令行, 命令行) = 真)
        .如果真 (信息框 (“您打开了S文档,请点是进入S文档界面。如取消,请按下快捷键ctrl+A进入阅读编辑模式”, 4, “滴水”, ) = #是钮)
            阅读模式_B ()
            载入 (阅读编辑_C, , 真)
        .如果真结束

    .如果真结束
    system.传入记录 = 假

下载信息 源码名称: 滴水记写本源码 源码适用: 易语言
下载地址
亦行
  • 版权声明: 发表于 2018-10-0115:27:22,共 502 字。
  • 转载注明:https://www.nanzl.com/archives/741

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: