滴水记写本完整开源(优秀学习源码)

yx 2018-10-0115:27:22滴水记写本完整开源(优秀学习源码)已关闭评论90.9K阅读1分40秒

滴水记写本是在滴水记事本基础上扩展而来,其文档加密和独立文本格式协议而具有一定的学习价值。内容编辑丰富,可制作表格等。新手初期接触易语言时此源码非常具有学习价值。但由于其交互繁琐,底层问题不断。也导致其不太好用。现公布其源码

滴水记写本完整开源(优秀学习源码)

‘初始段代码’

.版本 2
.支持库 iext2

.局部变量 命令行, 文本型, , "0"

资源加载 (#皮肤_win10, , , , )
阅读按钮.可视 = 假
全局通用变量.传入保存方式 = 1
全局阅读变量.定义是否传入 = 2
通用对话框1.初始目录 = 取运行目录 ()
全局通用变量.记写本标题 = 读配置项 (取运行目录 () + “\Set\core.ini”, “记写本信息”, “BT”, #名称)
_启动窗口.标题 = 全局通用变量.记写本标题
取命令行 (命令行)
系统_初始化 (取窗口句柄 ())
system.传入记录 = 真
.如果真 (取数组成员数 (命令行) ≠ 0)
    .如果真 (模块_后缀解密转义 (命令行, 命令行) = 真)
        .如果真 (信息框 (“您打开了S文档,请点是进入S文档界面。如取消,请按下快捷键ctrl+A进入阅读编辑模式”, 4, “滴水”, ) = #是钮)
            阅读模式_B ()
            载入 (阅读编辑_C, , 真)
        .如果真结束

    .如果真结束
    system.传入记录 = 假

下载信息 源码名称: 滴水记写本源码 源码适用: 易语言
下载地址
世界唯一不变的就是变化,世界唯一可能的就是不可能。
易语言DLL公开程序中无法自定义数据类型解决办法 技术分享

易语言DLL公开程序中无法自定义数据类型解决办法

在编写动态链接库时发现无法公开自定义数据库,只能提供基本数据库且不包含字节集。   其报错为 错误(10063): 被取地址的子程序“Entrance”的参数 2 必须是基本数据类型,且不能...
了解和掌握易语言面向对象 技术分享

了解和掌握易语言面向对象

许久许久,忙于工作和结婚无法更新一些实用的技术文章,趁女神节有点业余时间写下这篇“面向对象”技术分享文章 前言  希望你在看完这篇文章后能够了解 面向对象的含义,了解什么是面向对象 知道什么是类,了解...
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...