易语言里“且”“并且”“或”“或者”他们有什么区别或者用法是什么

yx 2018-11-2022:54:43易语言里“且”“并且”“或”“或者”他们有什么区别或者用法是什么已关闭评论150.5K阅读1分44秒
知识库内的解释
  1. 或/或者:如果所提供的两个参数逻辑值中任意有一个为真则返回真,否则返回假
  2. 且/并且:如果所提供的两个参数逻辑值都为真则返回真,否则返回假

注意:或/或者他们等意,且/并且他们等意。他们之间最主要的区别就在于“或”所提供的比较参数只需要等于一个参数“且”提供的所有比较参数都需要等于。

“等于”:只需要把他们看做一个比较即可

  1. 整数A = 1
  2. 文本B = “1”
  3. 逻辑C = 真/假

运用

  1.  或/或者

易语言里“且”“并且”“或”“或者”他们有什么区别或者用法是什么

// 从这里我们可以看出,只需要满足其中一个条件即可输出等于

.版本 2

.子程序 _按钮1_被单击
.局部变量 局部_参数一, 整数型

局部_参数一 = 1
.判断开始 (局部_参数一 = 到整数 (编辑框1.内容) 或 局部_参数一 > 到整数 (编辑框1.内容))
    输出调试文本 (编辑框1.内容, “等于”)
.默认
    输出调试文本 (编辑框1.内容, “不等于”)

  1. 且/并且

易语言里“且”“并且”“或”“或者”他们有什么区别或者用法是什么

// 我们可以看到,必须满足全部条件才能输出等于


.版本 2

.子程序 _按钮1_被单击
.局部变量 局部_参数一, 整数型
.局部变量 局部_参数二, 整数型

局部_参数一 = 1
局部_参数二 = 1
.判断开始 (局部_参数一 = 1 且 局部_参数二 > 到整数 (编辑框1.内容))
    输出调试文本 (编辑框1.内容, “等于”)
.默认
    输出调试文本 (编辑框1.内容, “不等于”)
.判断结束

世界唯一不变的就是变化,世界唯一可能的就是不可能。
易语言DLL公开程序中无法自定义数据类型解决办法 技术分享

易语言DLL公开程序中无法自定义数据类型解决办法

在编写动态链接库时发现无法公开自定义数据库,只能提供基本数据库且不包含字节集。   其报错为 错误(10063): 被取地址的子程序“Entrance”的参数 2 必须是基本数据类型,且不能...
WindowsAPI易语言内介绍和使用 技术分享

WindowsAPI易语言内介绍和使用

引用百度百科介绍:Windows 这个多作业系统除了协调应用程序的执行、分配内存、管理资源之外, 它同时也是一个很大的服务中心,调用这个服务中心的各种服务(每一种服务就是一个函数),可以帮应用程式达到...
了解和掌握易语言面向对象 技术分享

了解和掌握易语言面向对象

许久许久,忙于工作和结婚无法更新一些实用的技术文章,趁女神节有点业余时间写下这篇“面向对象”技术分享文章 前言  希望你在看完这篇文章后能够了解 面向对象的含义,了解什么是面向对象 知道什么是类,了解...
百度统计/SSP等新建或验证网站失败解决办法 技术分享

百度统计/SSP等新建或验证网站失败解决办法

在这里我必须吐槽一下百度了,竟然不支持HTTPS验证 看到引用了吗? 获取验证文件失败或文件错误,请您确认正确放置后,再次点击“完成验证”按钮” 你没有看错,因为百度不支持HTTPS验证,你需要关掉H...