易语言里“且”“并且”“或”“或者”他们有什么区别或者用法是什么

yx 技术探讨易语言里“且”“并且”“或”“或者”他们有什么区别或者用法是什么已关闭评论145,062字数 522阅读1分44秒阅读模式
知识库内的解释
  1. 或/或者:如果所提供的两个参数逻辑值中任意有一个为真则返回真,否则返回假
  2. 且/并且:如果所提供的两个参数逻辑值都为真则返回真,否则返回假

注意:或/或者他们等意,且/并且他们等意。他们之间最主要的区别就在于“或”所提供的比较参数只需要等于一个参数“且”提供的所有比较参数都需要等于。

“等于”:只需要把他们看做一个比较即可文章源自楠竹林-https://www.nanzl.com/archives/826

  1. 整数A = 1
  2. 文本B = “1”
  3. 逻辑C = 真/假

运用

  1.  或/或者

易语言里“且”“并且”“或”“或者”他们有什么区别或者用法是什么文章源自楠竹林-https://www.nanzl.com/archives/826

// 从这里我们可以看出,只需要满足其中一个条件即可输出等于文章源自楠竹林-https://www.nanzl.com/archives/826

.版本 2

.子程序 _按钮1_被单击
.局部变量 局部_参数一, 整数型

局部_参数一 = 1
.判断开始 (局部_参数一 = 到整数 (编辑框1.内容) 或 局部_参数一 > 到整数 (编辑框1.内容))
    输出调试文本 (编辑框1.内容, “等于”)
.默认
    输出调试文本 (编辑框1.内容, “不等于”)

  1. 且/并且

易语言里“且”“并且”“或”“或者”他们有什么区别或者用法是什么文章源自楠竹林-https://www.nanzl.com/archives/826

// 我们可以看到,必须满足全部条件才能输出等于文章源自楠竹林-https://www.nanzl.com/archives/826


.版本 2

.子程序 _按钮1_被单击
.局部变量 局部_参数一, 整数型
.局部变量 局部_参数二, 整数型

局部_参数一 = 1
局部_参数二 = 1
.判断开始 (局部_参数一 = 1 且 局部_参数二 > 到整数 (编辑框1.内容))
    输出调试文本 (编辑框1.内容, “等于”)
.默认
    输出调试文本 (编辑框1.内容, “不等于”)
.判断结束

文章源自楠竹林-https://www.nanzl.com/archives/826文章源自楠竹林-https://www.nanzl.com/archives/826