易语言用系统函数实现文件浏览效果/列出指定文件夹内容

实现编程语言为易语言,所用到的函数集合到WinApi2.6中(点击下载)

效果图

易语言用系统函数实现文件浏览效果/列出指定文件夹内容

所要用到的函数

  1. API_SetWindowLong
  2. API_DlgDirList
  3. API_SetWindowLong
  4. API_DlgDirListComboBox
  5. API_AtlAxWinInit
  6. API_CreateWindowEx
  7. AtlAxGetControl
.版本 2

.程序集 窗口程序集_窗口1
.程序集变量 obj, 对象

.子程序 _按钮1_被单击
.局部变量 hWnd, 整数型

API_SetWindowLong (列表框1.取窗口句柄 (), -12, 1001)
API_DlgDirList (取窗口句柄 (), “C:\Windows\AppPatch”, 1001, 0, 5)
API_SetWindowLong (组合框1.取窗口句柄 (), -12, 1002)
API_DlgDirListComboBox (取窗口句柄 (), “C:\Windows\AppPatch”, 1002, 0, 5)
API_AtlAxWinInit ()
hWnd = API_CreateWindowEx (0, “AtlAxWin”, “Shell.Explorer.1”, 十六进制 (“50000000”), 256, 28, 280, 260, 取窗口句柄 (), 1003, 0, 0)
AtlAxGetControl (hWnd, obj)
obj.数值方法 (“Navigate”, “C:\Windows\AppPatch\”)

下载信息 源码名称: 文件效果 源码适用: 易语言
下载地址
亦行
  • 版权声明: 发表于 2019-01-0219:36:43,共 606 字。
  • 转载注明:https://www.nanzl.com/archives/873

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: