易语言用系统函数实现文件浏览效果/列出指定文件夹内容

  • 易语言用系统函数实现文件浏览效果/列出指定文件夹内容已关闭评论
  • 128,414

实现编程语言为易语言,所用到的函数集合到WinApi2.6中(点击下载)

效果图

易语言用系统函数实现文件浏览效果/列出指定文件夹内容

所要用到的函数

  1. API_SetWindowLong
  2. API_DlgDirList
  3. API_SetWindowLong
  4. API_DlgDirListComboBox
  5. API_AtlAxWinInit
  6. API_CreateWindowEx
  7. AtlAxGetControl
.版本 2

.程序集 窗口程序集_窗口1
.程序集变量 obj, 对象

.子程序 _按钮1_被单击
.局部变量 hWnd, 整数型

API_SetWindowLong (列表框1.取窗口句柄 (), -12, 1001)
API_DlgDirList (取窗口句柄 (), “C:\Windows\AppPatch”, 1001, 0, 5)
API_SetWindowLong (组合框1.取窗口句柄 (), -12, 1002)
API_DlgDirListComboBox (取窗口句柄 (), “C:\Windows\AppPatch”, 1002, 0, 5)
API_AtlAxWinInit ()
hWnd = API_CreateWindowEx (0, “AtlAxWin”, “Shell.Explorer.1”, 十六进制 (“50000000”), 256, 28, 280, 260, 取窗口句柄 (), 1003, 0, 0)
AtlAxGetControl (hWnd, obj)
obj.数值方法 (“Navigate”, “C:\Windows\AppPatch\”)

下载信息 源码名称: 文件效果 源码适用: 易语言
下载地址
亦行
  • 本文由 发表于 2019-01-0219:36:43
易语言DLL公开程序中无法自定义数据类型解决办法 技术分享

易语言DLL公开程序中无法自定义数据类型解决办法

在编写动态链接库时发现无法公开自定义数据库,只能提供基本数据库且不包含字节集。   其报错为 错误(10063): 被取地址的子程序“Entrance”的参数 2 必须是基本数据类型,且不能...
了解和掌握易语言面向对象 技术分享

了解和掌握易语言面向对象

许久许久,忙于工作和结婚无法更新一些实用的技术文章,趁女神节有点业余时间写下这篇“面向对象”技术分享文章 前言  希望你在看完这篇文章后能够了解 面向对象的含义,了解什么是面向对象 知道什么是类,了解...
用易包来写易程序的小程序/插件/甚至可以写补丁 源码例程

用易包来写易程序的小程序/插件/甚至可以写补丁

如果说易模块相当于C语言里面的lib文件,则易包就相当于dll文件,也就是说,易模块是在易程序之间建立静态共享,而易包是建立动态共享,避免以前易模块修改后需要重新编译所有使用了它的易程序的问题,普通的...